[开源]自定义回复v1.6.1 支持部分晨风变量 可调用晨风插件

  [复制链接]
查看: 3097   回复: 373
rain 发表于 2020-8-5 19:35:42 | 显示全部楼层 |阅读模式
本帖最后由 rain 于 2020-8-22 12:20 编辑

1.6.1
1.插件给某个群发消息的时候可以用SendMessageA_整数 ()
第一个参数请读取自定义回复/设置/窗口句柄.txt
第二个参数为1301
第三个参数为机器人QQ|来源群号|来源QQ 例如 10001|200002|300003
第四个参数为要发送的消息内容
第三个和第四个参数都用数据的指针地址
/*发送消息子程序示例
.版本 2
.子程序 发送消息
.参数 QQID, 文本型
.参数 fromGroup, 文本型
.参数 fromQQ, 文本型
.参数 content, 文本型
.局部变量 return, 文本型
.局部变量 param, 文本型

return = 到文本 (读入文件 (取运行目录 () + “\自定义回复\设置\窗口句柄.txt”))
param = QQID + “|” + fromGroup + “|” + fromQQ
SendMessageA_整数 (到整数 (return), 1301, 取变量数据地址_文本 (param), 取变量数据地址_文本 (content))
*/
2.输出到框架日志也可以用SendMessageA_整数()
第一个参数请读取自定义回复/设置/窗口句柄.txt
第二个参数为1302
第三个参数为日志内容(使用字符串的地址)
第四个参数为日志文字颜色代码
3.增加变量$送礼物10001 20$10001为对方qq 20为礼物id
礼物id列表 :367告白话筒;299卡布奇诺;302猫咪手表;280牵你的手;281可爱猫咪;284神秘面具;285甜wink;286我超忙的;289快乐肥宅水;290幸运手链;313坚强;307绒绒手套; 312爱心口罩;308彩虹糖果。
4.所有内容可以加上$不回复此句$即只执行不回复
常用变量:
$QQ$ 发送者QQ
$数字1$  发送者QQ
$数字1无空格$
$数字1$  对方发消息过来的第一个qq号,如果没指定的话,就是发消息者的qq号,如果你要发的不是一个qq号,而只是普通的数字,那么在游戏语句后面要加一个【数字1非QQ】的标志。
$数字2$  对方发消息过来的第二个数字,如果那个游戏语句中没用到$数字1$,那么$数字2$就是指代对方发消息过来的第一个数字。
$回声$         对方发来消息的内容。
$完整回声$
$汉字回声$
$完整汉字回声$(和$汉字回声$变量一样,用于捕获群友输入的汉字,不包括其中的数字。)
$财富总额$(所有类似的变量后面都可以接一个qq号来获取指定qq号对应的值,比如$昵称68663216$、$财富总额10001$、$宝物10001$等)
$是否vip身份$
$宝物$(查询当前群某人宝物可用$宝物xxx$ 查询其他群某人宝物可用$宝物xxx yyy$)
$宝物序号1$
$宝物序号1 10001$即代表10001第1个宝物。
$昵称$
$是否管理员身份$(查询某个人在某个群是否为管理可以用$是否管理员身份xxx yyy$ xxx为对方qq yyy为所在群)
$群名称$
$群名片$
$群号码$
$QQ无空格$
$当前时间$
$当前时间年$
$当前时间月$
$当前时间日$
$当前时间时$
$当前时间分$
$当前时间秒$
奖惩指令:
$奖励2万$   $奖励10001 2万$
$设置积分300$  $设置积分200068663216 300$
$销毁导弹$
$赠予匕首$
$设置宝物玫瑰石$
$添加宝物匕首$ $添加宝物$和$设置宝物$的区别在于,后者会清空之前的宝物,直接重新设置,而前者是添加一个物品到宝物栏中(与$赠予匕首$不同,赠予匕首会自动判断匕首应该放在武器一栏还是放在宝物一栏,$添加宝物$是一定会放在宝物一栏的。而且不像$设置宝物$,$添加宝物$不能用+号连接一次添加多个宝物)。
$修改宝物$QQ$ 1 某某某$(修改当前qq号第一个宝物为某某某)、$修改宝物200013402429 2 某某某$(这个意思是修改200013402429这个虚拟qq号的第2个宝物内容为某某某)
如果你使用了$修改宝物$QQ$ 6 某某某$,但是前面5个宝物你没有赋值过,它们就会被默认初始化成未分配1、未分配2、未分配3之类的。通过这种技术,你可以给一些特殊的宝物一个固定的位置,而不用担心它的前面没有其它宝物而没办法直接指定。
$踢出$
//暂无这个变量$拉黑$
$禁言10分钟$
//暂无这个变量$禁闭10分钟$
$清零$
$解除禁言13402429$
条件语句:
%宝物要求有1;2;3%(代表着只要1;2;3任意一个有的话,就满足条件,如果是要1;2;3都有才算满足条件的话,则只需写成%宝物要求有1+2+3%。)
%宝物要求无1;2;3% (代表着只要1;2;3任意一个有的话,就不满足条件,如果是要1;2;3都有才算不满足条件的话,则只需写成%宝物要求无1+2+3%)
%宝物要求10001有xxxx%
%条件要求%只支持“<、>、=、!=”4种运算符号,如果“=、!=”号两边是汉字的话,它的意思是包含和不包含的意思。
//还没有这个变量$随机萌体字$
$随机表情$
如果要向群里发闪图或者向好友发闪图的话,只需要用[imgurl]C:\Users\chenfeng\Pictures\get_thumbnail333.jpg[/imgurl]【发闪照】
%积分要求2000%
%积分要求<2000%
%积分要求>2000%
%积分要求2000 隐藏%
%积分要求2000(你的积分不够)%
%积分要求10001>3000%
支持多个变量之间使用加减乘除,比如
$奖励20001$QQ无空格$ $财富总额20002$QQ无空格$$*$财富总额20003$QQ无空格$$$



可以在自定义回复文件夹中创建.txt文件编写,格式如下(一行一回复)
指令     回复
测试     6666666
//测试   这样便可以注释掉
回复下载(插件+源码):
游客,如果您要查看本帖隐藏内容请回复


最近不再更新


小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复 关闭延时

使用道具 举报

默淮 发表于 2020-8-5 19:46:21 | 显示全部楼层
看了LZ的帖子,我只想说一句很好很强大!
Moh 小白一枚 日常修仙 常年不在
回复

使用道具 举报

默淮 发表于 2020-8-5 19:46:25 | 显示全部楼层
看帖看完了至少要顶一下,还可以加入到淘帖哦!
Moh 小白一枚 日常修仙 常年不在
回复

使用道具 举报

landuo 发表于 2020-8-5 19:57:56 | 显示全部楼层
楼主我又看到你了
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

珉朝 发表于 2020-8-5 20:18:29 | 显示全部楼层
不错,又占了一个沙发!
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

我是萌新 发表于 2020-8-5 20:26:24 | 显示全部楼层
啥也不说了,楼主就是给力!
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

NEK 发表于 2020-8-5 20:29:04 | 显示全部楼层
谢谢楼主,好用!
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

chen812630 发表于 2020-8-5 20:29:13 | 显示全部楼层
啥也不说了,楼主就是给力!
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

2974560682 发表于 2020-8-5 21:28:40 | 显示全部楼层
本帖最后由 2974560682 于 2020-8-9 15:48 编辑

支持支持希望弄多点变量,不得不说是个非常好还免费的插件!
还有就是网址显示内容那个变量我这里测试是有点问题不会正常显示


小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

Eelgy 发表于 2020-8-5 21:30:32 | 显示全部楼层
不错,又占了一个沙发!
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

rain

楼主

|Archiver|手机版|小黑屋|小栗子机器人社区

Powered by 小栗子机器人社区 X3.4 © 2001-2020 Comsenz Inc.