一直在想怎么不用死循环和时钟可以做到每日签到,方法...

[复制链接]
查看: 296   回复: 7
陌语憨憨 发表于 2020-8-21 11:10:02 | 显示全部楼层 |阅读模式
本帖最后由 陌语憨憨 于 2020-8-21 11:11 编辑


.局部变量 时间, 日期时间型
.局部变量 新时间, 文本型


时间 = 取现行时间 ()
新时间 = 到文本 (取年份 (时间)) + “年” + 到文本 (取月份 (时间)) + “月” + 到文本 (取日 (时间)) + “日”
.如果真 (到文本 (读入文件 (取运行目录 () + “\陌语群管\签到信息1.my”)) ≠ 新时间)
    删除文件 (取运行目录 () + “\陌语群管\签到信息1.my”)‘签到信息1里面存储的是当日已签到的qq号
    删除文件 (取运行目录 () + “\陌语群管\签到信息2.my”)
    写到文件 (取运行目录 () + “\陌语群管\签到信息1.my”, 到字节集 (新时间))
.如果真结束


.局部变量 时间, 日期时间型
.局部变量 新时间, 文本型


时间 = 取现行时间 ()
新时间 = 到文本 (取年份 (时间)) + “年” + 到文本 (取月份 (时间)) + “月” + 到文本 (取日 (时间)) + “日”
.如果真 (到文本 (读入文件 (取运行目录 () + “\陌语群管\签到信息1.my”)) ≠ 新时间)
    删除文件 (取运行目录 () + “\陌语群管\签到信息1.my”)‘签到信息1里面存储的是当日已签到的qq号
    删除文件 (取运行目录 () + “\陌语群管\签到信息2.my”)
    写到文件 (取运行目录 () + “\陌语群管\签到信息1.my”, 到字节集 (新时间))
.如果真结束


就这样吧,不知道有没有人会使用这个方法,有什么疑问底下评论
陌语QQ:408617785
回复 关闭延时

使用道具 举报

sxm 发表于 2020-8-21 11:12:41 | 显示全部楼层
自动?
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

玄武国首席刺客 发表于 2020-8-21 16:57:57 | 显示全部楼层
你可以用crontab来做。
一如既往,就这样。
回复

使用道具 举报

 楼主| 陌语憨憨 发表于 2020-8-21 17:04:20 | 显示全部楼层

好办法
陌语QQ:408617785
回复

使用道具 举报

wkdd 发表于 2020-9-1 00:20:37 | 显示全部楼层

请教一下,易语言怎么去用crontab呢,有相应的模块吗?或者能提供一个简单的demo吗? 先谢谢了
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

许微末 发表于 2020-9-1 00:42:34 | 显示全部楼层
什么意思,看不明白,要判断干什么。。。
你这判不判断不都是在    签到信息1.my  这个文件里写入当前的时间吗
还有,注释里签到信息1里面不是QQ号吗,为什么最后要把时间写在里面,信息1里面到底是什么数据
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

小风筝 发表于 2020-9-1 00:51:27 | 显示全部楼层
我一直都是这样的啊,有消息就取现行时间判断一次,不是今天就重新更新一下
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

13只shmily 发表于 2020-9-12 09:45:36 | 显示全部楼层
    子程序名:时间_到文本
    返回文本格式的现行时间,如:2005053107123
    返回值类型:文本型
    参数<1>的名称为“操作时间”,类型为“日期时间型”,允许接收空参数数据。注明:可空。留空为现行时间。
    参数<2>的名称为“输出格式”,类型为“整数型”,允许接收空参数数据。注明:可空。0=N年N月N日 N时N分N秒  1=年-月-日 时:分:秒  2=年/月/日 时/分/秒  3=年月日时分秒。
    参数<3>的名称为“取出类型”,类型为“整数型”,允许接收空参数数据。注明:可空。留空为全部,1=只取年月日,2=取月日,3=只取时分秒,4=时分,5=分秒。

一句话那么简单。.
版本 2
写配置项 (取运行目录 () + “1.ini”, “签到日期”, “qq123456”, 时间_到文本 (, 0, 1))
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

陌语憨憨

楼主

|Archiver|手机版|小黑屋|小栗子机器人社区

Powered by 小栗子机器人社区 X3.4 © 2001-2020 Comsenz Inc.