壹盾安全Cdn,小栗子论坛都在使用的Cdn
10核32G挂机宝5元|低价服务器|代理更优惠|自主研发|
【推荐】 SUB·优质插件 目录导航点击留言举报社区广告(周末处理)

另一种小栗子取框架QQ的写法

[复制链接]
查看: 139   回复: 4
708898471 发表于 2021-9-2 13:07:12 | 显示全部楼层 |阅读模式

.版本 2
.支持库 spec

调试输出 (小栗子取框架QQ ())

.子程序 小栗子取框架QQ, 文本型, 公开
.局部变量 框架数据, 文本型
.局部变量 起始位置, 整数型, , , 登录完毕/未登录
.局部变量 后续位置, 整数型
.局部变量 最后位置, 整数型
.局部变量 返回数据, 文本型

框架数据 = #常量2  ' xlz.取框架QQ ()
起始位置 = 寻找文本 (框架数据, “登录完毕”, 1, 假)
后续位置 = 倒找文本 (框架数据, #引号 + “:{” + #引号 + “昵称”, 起始位置, 假)
最后位置 = 倒找文本 (框架数据, #引号, 后续位置, 假)
返回数据 = 文本_取出中间文本 (框架数据, #引号, #引号 + “:{”, 最后位置, 假)
返回 (返回数据)


本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
小栗子社区文字广告位 联系===》QQ1917703871
回复 关闭延时

使用道具 举报

温湿度 发表于 2021-9-2 13:14:45 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

阳光小子 发表于 2021-9-2 13:17:03 | 显示全部楼层
直接json不是更好?
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

星辰吖 发表于 2021-9-2 13:18:45 | 显示全部楼层
啥也不说了,楼主就是给力!
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

温湿度 发表于 2021-9-2 13:21:21 | 显示全部楼层
提示: 作者被禁止或删除 内容自动屏蔽
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

708898471

2

主题

44

帖子

64

积分

新手上路

Rank: 1

积分
64

|Archiver|手机版|小栗子机器人社区 ( 琼ICP备2020005018号-14 )|网站地图

Powered by Discuz! X3.4 © 2001-2018 Comsenz Inc.