壹盾安全Cdn,小栗子论坛都在使用的Cdn
10核32G挂机宝5元|低价服务器|代理更优惠|自主研发|
【推荐】 SUB·优质插件 目录导航免费群管插件Q群748833831免费微信娱乐插件Q群748833831免费QQ抢红包插件Q群748833831
免费娱乐群管插件Q群748833831 重金悬赏定制开发群外提取群成员,监控进群退群QQ群监控吸粉软件,进退群邮件提示
免费微信娱乐插件Q群748833831DNF手游阿拉德之怒福利私服火热公测加1群1005332797
守护者插件系列授权DNF手游阿拉德之怒福利私服火热公测加2群521898166
超强QQ群管系统 (搭配牛逼发卡系统)超强助手插件(支持秒抢各种红包)小栗子框架 Pro购买 (无手续费)

有无大佬给个报时思路

[复制链接]
查看: 272   回复: 34
411123 发表于 2021-9-1 19:04:20 | 显示全部楼层 |阅读模式
100栗子
整点报时 怎么判断时间
整点后自动发送时间

最佳答案

查看完整内容

不麻烦啊,几句代码的事,就算传参也需要用这两个api获取参数啊,还不如直接在报时子程序里面调用
小栗子社区文字广告位 联系===》QQ1917703871
回复 关闭延时

使用道具 举报

宫内莲华 发表于 2021-9-1 19:04:21 | 显示全部楼层
411123 发表于 2021-9-2 12:54
这么麻烦的大佬

不麻烦啊,几句代码的事,就算传参也需要用这两个api获取参数啊,还不如直接在报时子程序里面调用
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

蔚然 发表于 2021-9-1 19:08:29 | 显示全部楼层
取现行时间的分秒都是0,然后剩下的就是整点了
2783287375
回复

使用道具 举报

411123 (楼主)   发表于 2021-9-1 19:14:02 | 显示全部楼层
蔚然 发表于 2021-9-1 19:08
取现行时间的分秒都是0,然后剩下的就是整点了

怎么让它自动发送,写在群消息 还得人触发才能发送
咋能自动发
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

蔚然 发表于 2021-9-1 19:14:46 | 显示全部楼层
.版本 2
.支持库 spec

.局部变量 time, 日期时间型
.局部变量 时, 整数型
.局部变量 分, 整数型
.局部变量 秒, 整数型

.判断循环首 (真)
    延迟 (500)
    time = 取现行时间 ()
    分 = 取分钟 (time)
    秒 = 取秒 (time)
    时 = 取小时 (time)
    .如果真 (分 = 0 且 秒 = 0)
        调试输出 (到文本 (时) + “:” + 到文本 (分) + “:” + 到文本 (秒))
    .如果真结束
    调试输出 (到文本 (时) + “:” + 到文本 (分) + “:” + 到文本 (秒))
.判断循环尾 ()
2783287375
回复

使用道具 举报

蔚然 发表于 2021-9-1 19:16:30 | 显示全部楼层
调试输出替换成发送即可
.版本 2
.支持库 spec

.局部变量 time, 日期时间型
.局部变量 时, 整数型
.局部变量 分, 整数型
.局部变量 秒, 整数型

.判断循环首 (真)
    延迟 (500)
    time = 取现行时间 ()
    分 = 取分钟 (time)
    秒 = 取秒 (time)
    时 = 取小时 (time)
    .如果真 (分 = 0 且 秒 = 0)
        api.发送群消息 (框架QQ,消息群号,到文本 (时) + “:” + 到文本 (分) + “:” + 到文本 (秒))
    .如果真结束



.判断循环尾 ()
2783287375
回复

使用道具 举报

蔚然 发表于 2021-9-1 19:18:34 | 显示全部楼层
记得给个好评亲
2783287375
回复

使用道具 举报

411123 (楼主)   发表于 2021-9-1 19:25:56 | 显示全部楼层
蔚然 发表于 2021-9-1 19:16
调试输出替换成发送即可
.版本 2
.支持库 spec

加在哪里呀,群消息里还是哪哦
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

蔚然 发表于 2021-9-1 19:38:56 | 显示全部楼层
411123 发表于 2021-9-1 19:25
加在哪里呀,群消息里还是哪哦

插件启动
2783287375
回复

使用道具 举报

411123 (楼主)   发表于 2021-9-1 21:01:06 | 显示全部楼层

数据类型用群消息类型么
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

1234下一页
您需要登录后才可以回帖   登录 立即注册

高级模式

411123

16

主题

140

帖子

301

积分

注册会员

Rank: 2

积分
301

|Archiver|手机版|小栗子机器人社区 ( 琼ICP备2020005018号-14 )|网站地图

Powered by Discuz! X3.4 © 2001-2018 Comsenz Inc.