学习交流插件开发心得

[复制链接]
查看: 175   回复: 5
A先生 发表于 2020-8-16 18:55:42 | 显示全部楼层 |阅读模式
本帖最后由 A先生 于 2020-8-16 19:11 编辑

==============群图片转好友图片代码=================

.版本 2

.子程序 群图片转好友图片, 文本型
.参数 框架QQ, 长整数型
.参数 消息群号, 长整数型
.参数 好友QQ, 长整数型
.参数 消息内容, 文本型
.局部变量 正则, 正则表达式类
.局部变量 图片链接, 文本型
.局部变量 i, 整数型
.局部变量 上传图片, 字节集
.局部变量 pic, 文本型
.局部变量 msg, 文本型
.局部变量 图片, 文本型

正则.创建 (“[pic,hash=[a-zA-Z0-9]*]”, 消息内容)
.判断开始 (正则.取匹配数量 () > 1)
    .计次循环首 (正则.取匹配数量 (), i)
        ' 图片 = “[pic” + 文本_取出中间文本 (正则.取匹配文本 (i, 1), “[pic”, “]”) + “]”
        图片链接 = Api.取图片下载地址 (正则.取匹配文本 (i, 1), 框架QQ, 消息群号)
        上传图片 = HTTP读文件 (图片链接)
        Api.输出日志 (“图片链接:” + 图片链接, #红色, #白色)
        pic = pic + Api.上传好友图片 (框架QQ,  好友QQ, , 上传图片)
        消息内容 = 子文本替换 (消息内容, 正则.取匹配文本 (i, 1), “”, , , 真)
    .计次循环尾 ()
    msg = pic + 消息内容
.默认
    图片 = “[pic” + 文本_取出中间文本 (消息内容, “[pic”, “]”) + “]”
    图片链接 = Api.取图片下载地址 (图片, 框架QQ, 消息群号)
    上传图片 = HTTP读文件 (图片链接)
    Api.输出日志 (“图片链接:” + 图片链接, #红色, #白色)
    pic = Api.上传好友图片 (框架QQ,  好友QQ, , 上传图片)
    消息内容 = 子文本替换 (消息内容, 图片, “”, , , 真)
    msg = pic + 消息内容
.判断结束

返回 (msg)


大家有好用的小功能子程序,可以分享一下。一起学习成长!!!

小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复 关闭延时

使用道具 举报

骑士学长 发表于 2020-8-17 00:17:24 | 显示全部楼层
哥顶的不是帖子,是寂寞!
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

空荡荡 发表于 2020-8-21 16:09:45 | 显示全部楼层
啥也不说了,楼主就是给力!
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

qingyan 发表于 2020-8-28 23:13:09 | 显示全部楼层
哥顶的不是帖子,是寂寞!
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

YeSilin 发表于 2020-9-3 23:09:56 | 显示全部楼层
感谢楼主~~~
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

kyle 发表于 2020-9-6 08:20:31 | 显示全部楼层
不管你信不信,反正我是信了。
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

|Archiver|手机版|小黑屋|小栗子机器人社区

Powered by 小栗子机器人社区 X3.4 © 2001-2020 Comsenz Inc.