壹盾安全Cdn,小栗子论坛都在使用的Cdn
10核32G挂机宝5元|低价服务器|代理更优惠|自主研发|
【推荐】 SUB·优质插件 目录导航免费群管插件Q群748833831免费微信娱乐插件Q群748833831免费QQ抢红包插件Q群748833831
免费娱乐群管插件Q群748833831 重金悬赏定制开发群外提取群成员,监控进群退群QQ群监控吸粉软件,进退群邮件提示
免费微信娱乐插件Q群748833831DNF手游阿拉德之怒福利私服火热公测加1群1005332797
守护者插件系列授权DNF手游阿拉德之怒福利私服火热公测加2群521898166
超强QQ群管系统 (搭配牛逼发卡系统)超强助手插件(支持秒抢各种红包)小栗子框架 Pro购买 (无手续费)

做插件时使用取文本的时候出现乱码,求解答

[复制链接]
查看: 98   回复: 3
ctpl 发表于 2021-8-21 02:02:03 | 显示全部楼层 |阅读模式
30栗子
刚刚开始学习,实在是搞不懂这个为什么乱码,求解答
.版本 2

.如果真 (数据.发送人QQ ≠ 数据.框架QQ 且 数据.发送人QQ ≠ 数据.框架QQqq匿名Id) ' 过滤自己(包括其他设备)的消息,你也可以不过滤
.如果真 (数据.发送人QQ = 到长整数 (“2446954097”))
.如果真 (到文本 (寻找文本 (数据.消息内容, “创建全局权限组”, 1, 假)) ≠ “-1”)
qjqxz = 取文本中间 (数据.消息内容, 8, 取文本长度 (数据.消息内容))
Api.发送群消息 (数据.框架QQ, 数据.消息群号, “创建全局权限组名称为” + qjqxz)
.版本 2

.如果真 (数据.发送人QQ ≠ 数据.框架QQ 且 数据.发送人QQ ≠ 数据.框架QQqq匿名Id) ' 过滤自己(包括其他设备)的消息,你也可以不过滤
.如果真 (数据.发送人QQ = 到长整数 (“2446954097”))
.如果真 (到文本 (寻找文本 (数据.消息内容, “创建全局权限组”, 1, 假)) ≠ “-1”)
qjqxz = 取文本中间 (数据.消息内容, 8, 取文本长度 (数据.消息内容))
Api.发送群消息 (数据.框架QQ, 数据.消息群号, “创建全局权限组名称为” + qjqxz)

最佳答案

查看完整内容

取文本中间这个命令的第二参数的单位是字符,一个汉字是占两个字符的;又因为取中间文本是从你第二个参数所填的位置开始取(包含该位置的字符)。综上所述,你这里的取文本中间的第二个参数应该填15。
小栗子社区文字广告位 联系===》QQ1917703871
回复 关闭延时

使用道具 举报

Drop 发表于 2021-8-21 02:02:04 | 显示全部楼层
本帖最后由 Drop 于 2021-8-21 02:36 编辑

取文本中间这个命令的第二参数的单位是字符,一个汉字是占两个字符的;又因为取中间文本是从你第二个参数所填的位置开始取(包含该位置的字符)。综上所述,你这里的取文本中间的第二个参数应该填15。
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

白井黑子 发表于 2021-8-21 02:14:06 | 显示全部楼层
用精易模块比较好哦:
变量qjqxz重新赋值为:
qjqxz = 文本_取右边(数据.消息内容,”创建全局权限组”)
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

阳光小子 发表于 2021-8-22 10:42:28 | 显示全部楼层
明显是你的截取位置问题导致的乱码,取文本中间这个命令使用不对
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

ctpl

3

主题

107

帖子

137

积分

新手上路

Rank: 1

积分
137

|Archiver|手机版|小栗子机器人社区 ( 琼ICP备2020005018号-14 )|网站地图

Powered by Discuz! X3.4 © 2001-2018 Comsenz Inc.