壹盾安全Cdn,小栗子论坛都在使用的Cdn
10核32G挂机宝5元|低价服务器|代理更优惠|自主研发|
【推荐】 SUB·优质插件 目录导航点击留言举报社区广告(周末处理)

开源第二弹,复制名片

[复制链接]
查看: 233   回复: 7
小陈同学 发表于 2021-8-15 23:21:28 | 显示全部楼层 |阅读模式
.版本 2
.支持库 spec




.子程序 获取名片代码, 文本型
.参数 获取到的名片数据, 文本型
.参数 当前名片模板数据, 文本型
.参数 底图, 文本型, 参考 可空
.局部变量 json, 类_json
.局部变量 i, 整数型
.局部变量 json2, 类_json
.局部变量 数组, 文本型, , "0"
.局部变量 y, 整数型
.局部变量 x_axis, 文本型
.局部变量 y_axis, 文本型
.局部变量 height, 文本型
.局部变量 width, 文本型
.局部变量 lpd, 文本型
.局部变量 content, 文本型
.局部变量 DIY名片数据, DIY名片数据
.局部变量 DIY名片数据数组, DIY名片数据, , "0"
.局部变量 属性值, 文本型
.局部变量 主题属性, 主题属性
.局部变量 待解析, 文本型



json.解析 (获取到的名片数据)
json2.解析 (当前名片模板数据)
json2.取所有属性名 (数组, “['render_info']['head_info']['head_items']”)


Api.输出日志 (获取到的名片数据)

.计次循环首 (取数组成员数 (数组), i)
    .如果真 (数组 ≠ “1001” 且 数组 ≠ “1002” 且 数组 ≠ “1003”)
        json2.置属性对象 (“['render_info']['head_info']['head_items']['” + 数组 + “']”, “”)
    .如果真结束

.计次循环尾 ()
json2.解析 (json2.取数据文本 ())
json2.取所有属性名 (数组, “['render_info']['head_info']['head_items']”)
底图 = json.取通用属性 (“bg[0].content”)


待解析 = json.取通用属性 (“body.arr”)
主题属性.style_id = 到整数 (json.取属性 (“body.id”).取数据文本 ())
主题属性.card_id = 到整数 (文本_取出中间文本 (待解析, “item/”, “/r/”))
主题属性.card_md5 = 文本_取出中间文本 (待解析, “/r/”, “-arr.png”)


待解析 = json.取通用属性 (“bg[2].content”)
主题属性.lottie_id = 文本_取出中间文本 (待解析, “customProfileAnimation/”, “/”)
主题属性.animation_md5 = 文本_取出中间文本 (待解析, 主题属性.lottie_id + “/”, “.zip”)
主题属性.mask_view = json.取通用属性 (“bg[1].content”)
主题属性.line = json.取通用属性 (“body.line”)
主题属性.color = json.取通用属性 (“body.c”)
主题属性.cpd = 到整数 (json.取属性 (“body.cpd”).取数据文本 ())


.如果真 (取文本长度 (主题属性.card_md5) > 32)
    主题属性.card_md5 = “”
.如果真结束


调试输出 (主题属性.style_id, 主题属性.card_id, 主题属性.card_md5, 主题属性.mask_view, 主题属性.line, 主题属性.color, 主题属性.cpd)

json2.置属性数值 (“['style_id']”, 主题属性.style_id)  ' 主体
json2.置属性数值 (“['card_id']”, 主题属性.card_id)
json2.置属性 (“['card_md5']”, 主题属性.card_md5)


json2.置属性 (“['render_info']['bg_info']['mask_view']”, 主题属性.mask_view)  ' 背景
json2.置属性 (“['render_info']['bg_info']['lottie_id']”, 主题属性.lottie_id)
json2.置属性 (“['render_info']['bg_info']['animation_md5']”, 主题属性.animation_md5)


json2.置属性 (“['render_info']['body_info'].color”, 主题属性.color)  ' 末尾,颜色’
json2.置属性数值 (“['render_info']['body_info'].cpd”, 主题属性.cpd)
json2.置属性 (“['render_info']['body_info']['line_color']”, 主题属性.line)


.计次循环首 (json.成员数 (“header.child”), i)
    DIY名片数据.c = json.取通用属性 (“header.child[” + 到文本 (i - 1) + “].content”)
    DIY名片数据.h = json.取通用属性 (“header.child[” + 到文本 (i - 1) + “].height”)
    DIY名片数据.w = json.取通用属性 (“header.child[” + 到文本 (i - 1) + “].width”)
    DIY名片数据.x = json.取通用属性 (“header.child[” + 到文本 (i - 1) + “].x”)
    DIY名片数据.y = json.取通用属性 (“header.child[” + 到文本 (i - 1) + “].y”)
    DIY名片数据.id = json.取通用属性 (“header.child[” + 到文本 (i - 1) + “].id”)
    DIY名片数据.l = 到整数 (json.取属性 (“header.child[” + 到文本 (i - 1) + “].lpd”).取数据文本 ())
    DIY名片数据.type = json.取通用属性 (“header.child[” + 到文本 (i - 1) + “].type”)
    加入成员 (DIY名片数据数组, DIY名片数据)
.计次循环尾 ()
.计次循环首 (取数组成员数 (DIY名片数据数组), i)
    .计次循环首 (取数组成员数 (数组), y)
        x_axis = “['render_info']['head_info']['head_items']['” + 数组 [y] + “']['position_info']['x_axis']”
        y_axis = “['render_info']['head_info']['head_items']['” + 数组 [y] + “']['position_info']['y_axis']”
        width = “['render_info']['head_info']['head_items']['” + 数组 [y] + “']['position_info'].width”
        height = “['render_info']['head_info']['head_items']['” + 数组 [y] + “']['position_info'].height”
        lpd = “['render_info']['head_info']['head_items']['” + 数组 [y] + “']['int_kv'].lpd”
        .如果真 (数组 [y] = DIY名片数据数组 .id 且 DIY名片数据数组 .c = “”)  ' 替换1001,1002,1003’
            json2.置属性 (x_axis, DIY名片数据数组 .x)
            json2.置属性 (y_axis, DIY名片数据数组 .y)
            .如果真 (json2.取通用属性 (width) ≠ “”)
                json2.置属性 (width, DIY名片数据数组 .w)
            .如果真结束
            .如果真 (json2.取通用属性 (height) ≠ “”)
                json2.置属性 (height, DIY名片数据数组 .h)
            .如果真结束
            .如果真 (json2.取属性 (lpd).取数据文本 () ≠ “”)
                json2.置属性数值 (lpd, DIY名片数据数组 .l)
            .如果真结束

            调试输出 (DIY名片数据数组 .id, DIY名片数据数组 .w, DIY名片数据数组 .h, DIY名片数据数组 .x, DIY名片数据数组 .y, DIY名片数据数组 .l)
        .如果真结束

    .计次循环尾 ()

    .如果真 (DIY名片数据数组 .c ≠ “”)


        属性值 = 到文本 (2060 + i)

        json2.置属性对象 (“['render_info']['head_info']['head_items']['1-” + 属性值 + “']”, #空白属性)
        json2.置属性 (“['render_info']['head_info']['head_items']['1-” + 属性值 + “']['position_info']['x_axis']”, DIY名片数据数组 .x)
        json2.置属性 (“['render_info']['head_info']['head_items']['1-” + 属性值 + “']['position_info']['y_axis']”, DIY名片数据数组 .y)
        json2.置属性 (“['render_info']['head_info']['head_items']['1-” + 属性值 + “']['position_info'].width”, DIY名片数据数组 .w)
        json2.置属性 (“['render_info']['head_info']['head_items']['1-” + 属性值 + “']['position_info'].height”, DIY名片数据数组 .h)
        json2.置属性 (“['render_info']['head_info']['head_items']['1-” + 属性值 + “']['str_kv'].content”, DIY名片数据数组 .c)
        json2.置属性 (“['render_info']['head_info']['head_items']['1-” + 属性值 + “']['str_kv'].type”, DIY名片数据数组 .type)


        调试输出 (DIY名片数据数组 .id, i, DIY名片数据数组 .c)
    .如果真结束

.计次循环尾 ()



返回 (json2.取数据文本 ())


.版本 2
.支持库 spec




.子程序 获取名片代码, 文本型
.参数 获取到的名片数据, 文本型
.参数 当前名片模板数据, 文本型
.参数 底图, 文本型, 参考 可空
.局部变量 json, 类_json
.局部变量 i, 整数型
.局部变量 json2, 类_json
.局部变量 数组, 文本型, , "0"
.局部变量 y, 整数型
.局部变量 x_axis, 文本型
.局部变量 y_axis, 文本型
.局部变量 height, 文本型
.局部变量 width, 文本型
.局部变量 lpd, 文本型
.局部变量 content, 文本型
.局部变量 DIY名片数据, DIY名片数据
.局部变量 DIY名片数据数组, DIY名片数据, , "0"
.局部变量 属性值, 文本型
.局部变量 主题属性, 主题属性
.局部变量 待解析, 文本型



json.解析 (获取到的名片数据)
json2.解析 (当前名片模板数据)
json2.取所有属性名 (数组, “['render_info']['head_info']['head_items']”)


Api.输出日志 (获取到的名片数据)

.计次循环首 (取数组成员数 (数组), i)
    .如果真 (数组 ≠ “1001” 且 数组 ≠ “1002” 且 数组 ≠ “1003”)
        json2.置属性对象 (“['render_info']['head_info']['head_items']['” + 数组 + “']”, “”)
    .如果真结束

.计次循环尾 ()
json2.解析 (json2.取数据文本 ())
json2.取所有属性名 (数组, “['render_info']['head_info']['head_items']”)
底图 = json.取通用属性 (“bg[0].content”)


待解析 = json.取通用属性 (“body.arr”)
主题属性.style_id = 到整数 (json.取属性 (“body.id”).取数据文本 ())
主题属性.card_id = 到整数 (文本_取出中间文本 (待解析, “item/”, “/r/”))
主题属性.card_md5 = 文本_取出中间文本 (待解析, “/r/”, “-arr.png”)


待解析 = json.取通用属性 (“bg[2].content”)
主题属性.lottie_id = 文本_取出中间文本 (待解析, “customProfileAnimation/”, “/”)
主题属性.animation_md5 = 文本_取出中间文本 (待解析, 主题属性.lottie_id + “/”, “.zip”)
主题属性.mask_view = json.取通用属性 (“bg[1].content”)
主题属性.line = json.取通用属性 (“body.line”)
主题属性.color = json.取通用属性 (“body.c”)
主题属性.cpd = 到整数 (json.取属性 (“body.cpd”).取数据文本 ())


.如果真 (取文本长度 (主题属性.card_md5) > 32)
    主题属性.card_md5 = “”
.如果真结束


调试输出 (主题属性.style_id, 主题属性.card_id, 主题属性.card_md5, 主题属性.mask_view, 主题属性.line, 主题属性.color, 主题属性.cpd)

json2.置属性数值 (“['style_id']”, 主题属性.style_id)  ' 主体
json2.置属性数值 (“['card_id']”, 主题属性.card_id)
json2.置属性 (“['card_md5']”, 主题属性.card_md5)


json2.置属性 (“['render_info']['bg_info']['mask_view']”, 主题属性.mask_view)  ' 背景
json2.置属性 (“['render_info']['bg_info']['lottie_id']”, 主题属性.lottie_id)
json2.置属性 (“['render_info']['bg_info']['animation_md5']”, 主题属性.animation_md5)


json2.置属性 (“['render_info']['body_info'].color”, 主题属性.color)  ' 末尾,颜色’
json2.置属性数值 (“['render_info']['body_info'].cpd”, 主题属性.cpd)
json2.置属性 (“['render_info']['body_info']['line_color']”, 主题属性.line)


.计次循环首 (json.成员数 (“header.child”), i)
    DIY名片数据.c = json.取通用属性 (“header.child[” + 到文本 (i - 1) + “].content”)
    DIY名片数据.h = json.取通用属性 (“header.child[” + 到文本 (i - 1) + “].height”)
    DIY名片数据.w = json.取通用属性 (“header.child[” + 到文本 (i - 1) + “].width”)
    DIY名片数据.x = json.取通用属性 (“header.child[” + 到文本 (i - 1) + “].x”)
    DIY名片数据.y = json.取通用属性 (“header.child[” + 到文本 (i - 1) + “].y”)
    DIY名片数据.id = json.取通用属性 (“header.child[” + 到文本 (i - 1) + “].id”)
    DIY名片数据.l = 到整数 (json.取属性 (“header.child[” + 到文本 (i - 1) + “].lpd”).取数据文本 ())
    DIY名片数据.type = json.取通用属性 (“header.child[” + 到文本 (i - 1) + “].type”)
    加入成员 (DIY名片数据数组, DIY名片数据)
.计次循环尾 ()
.计次循环首 (取数组成员数 (DIY名片数据数组), i)
    .计次循环首 (取数组成员数 (数组), y)
        x_axis = “['render_info']['head_info']['head_items']['” + 数组 [y] + “']['position_info']['x_axis']”
        y_axis = “['render_info']['head_info']['head_items']['” + 数组 [y] + “']['position_info']['y_axis']”
        width = “['render_info']['head_info']['head_items']['” + 数组 [y] + “']['position_info'].width”
        height = “['render_info']['head_info']['head_items']['” + 数组 [y] + “']['position_info'].height”
        lpd = “['render_info']['head_info']['head_items']['” + 数组 [y] + “']['int_kv'].lpd”
        .如果真 (数组 [y] = DIY名片数据数组 .id 且 DIY名片数据数组 .c = “”)  ' 替换1001,1002,1003’
            json2.置属性 (x_axis, DIY名片数据数组 .x)
            json2.置属性 (y_axis, DIY名片数据数组 .y)
            .如果真 (json2.取通用属性 (width) ≠ “”)
                json2.置属性 (width, DIY名片数据数组 .w)
            .如果真结束
            .如果真 (json2.取通用属性 (height) ≠ “”)
                json2.置属性 (height, DIY名片数据数组 .h)
            .如果真结束
            .如果真 (json2.取属性 (lpd).取数据文本 () ≠ “”)
                json2.置属性数值 (lpd, DIY名片数据数组 .l)
            .如果真结束

            调试输出 (DIY名片数据数组 .id, DIY名片数据数组 .w, DIY名片数据数组 .h, DIY名片数据数组 .x, DIY名片数据数组 .y, DIY名片数据数组 .l)
        .如果真结束

    .计次循环尾 ()

    .如果真 (DIY名片数据数组 .c ≠ “”)


        属性值 = 到文本 (2060 + i)

        json2.置属性对象 (“['render_info']['head_info']['head_items']['1-” + 属性值 + “']”, #空白属性)
        json2.置属性 (“['render_info']['head_info']['head_items']['1-” + 属性值 + “']['position_info']['x_axis']”, DIY名片数据数组 .x)
        json2.置属性 (“['render_info']['head_info']['head_items']['1-” + 属性值 + “']['position_info']['y_axis']”, DIY名片数据数组 .y)
        json2.置属性 (“['render_info']['head_info']['head_items']['1-” + 属性值 + “']['position_info'].width”, DIY名片数据数组 .w)
        json2.置属性 (“['render_info']['head_info']['head_items']['1-” + 属性值 + “']['position_info'].height”, DIY名片数据数组 .h)
        json2.置属性 (“['render_info']['head_info']['head_items']['1-” + 属性值 + “']['str_kv'].content”, DIY名片数据数组 .c)
        json2.置属性 (“['render_info']['head_info']['head_items']['1-” + 属性值 + “']['str_kv'].type”, DIY名片数据数组 .type)


        调试输出 (DIY名片数据数组 .id, i, DIY名片数据数组 .c)
    .如果真结束

.计次循环尾 ()



返回 (json2.取数据文本 ())




交流群:点击链接加入群聊【如何优雅的玩转Robot】:https://jq.qq.com/?_wv=1027&k=W1vG6dxz

回复 关闭延时

使用道具 举报

库伊拉 发表于 2021-8-15 23:29:18 | 显示全部楼层
噢 又一个沙发
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

Succubus 发表于 2021-8-15 23:29:39 | 显示全部楼层
我是板凳~
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

Alasion 发表于 2021-8-15 23:31:42 | 显示全部楼层
膜拜神贴,后面的请保持队形~
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

Q子言 发表于 2021-8-15 23:32:01 | 显示全部楼层
不错,又占了一个沙发!
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

树皮 发表于 2021-8-15 23:53:36 | 显示全部楼层
支持小陈!!
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

王思聪 发表于 2021-8-16 14:11:50 | 显示全部楼层
支持 老陈
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

白井黑子 发表于 2021-8-17 22:48:13 | 显示全部楼层
顶小陈带老佬
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

小陈同学

18

主题

210

帖子

432

积分

超级版主

Rank: 8Rank: 8

积分
432
QQ

|Archiver|手机版|小栗子机器人社区 ( 琼ICP备2020005018号-14 )|网站地图

Powered by Discuz! X3.4 © 2001-2018 Comsenz Inc.