壹盾安全Cdn,小栗子论坛都在使用的Cdn
10核32G挂机宝5元|低价服务器|代理更优惠|自主研发|
【推荐】 SUB·优质插件 目录导航点击留言举报社区广告(周末处理)

很久没发帖了,开源几个东西【奥运金牌榜】

[复制链接]
查看: 172   回复: 2
小陈同学 发表于 2021-8-15 23:12:44 | 显示全部楼层 |阅读模式
.版本 2
.支持库 commobj

.子程序 金牌榜, 文本型
.局部变量 Data, 文本型
.局部变量 Json, 类_json
.局部变量 文本, 快速文本对象
.局部变量 i, 整数型
.局部变量 金牌, 文本型
.局部变量 银牌, 文本型
.局部变量 铜牌, 文本型
.局部变量 总数, 文本型
.局部变量 国家, 文本型
.局部变量 代号, 文本型
.局部变量 局_网址, 文本型
.局部变量 局_方式, 整数型
.局部变量 ADD_协议头, 类_POST数据类
.局部变量 局_提交协议头, 文本型
.局部变量 局_结果, 字节集


局_网址 = “https://www.baidu.com/s?ie=utf-8 ... 1%E7%89%8C%E6%A6%9C
局_方式 = 0
ADD_协议头.添加 (“User-Agent”, “Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.87 Safari/537.36”)

局_提交协议头 = ADD_协议头.获取协议头数据 ()

局_结果 = 网页_访问_对象 (局_网址, 局_方式, , , , 局_提交协议头)

Data = 到文本 (编码_编码转换对象 (局_结果))

Data = 文本_取出中间文本 (Data, “}]}},”, “,{” + #引号 + “tempName” + #引号 + “:” + #引号)
Json.解析 (Data)
.计次循环首 (Json.成员数 (“tplData.dataList”), i)
    国家 = Json.取通用属性 (“tplData.dataList[” + 到文本 (i - 1) + “].name”)
    代号 = Json.取通用属性 (“tplData.dataList[” + 到文本 (i - 1) + “].countryAbbr”)
    金牌 = Json.取通用属性 (“tplData.dataList[” + 到文本 (i - 1) + “].gold”)
    银牌 = Json.取通用属性 (“tplData.dataList[” + 到文本 (i - 1) + “].silver”)
    铜牌 = Json.取通用属性 (“tplData.dataList[” + 到文本 (i - 1) + “].copper”)
    总数 = Json.取通用属性 (“tplData.dataList[” + 到文本 (i - 1) + “].count”)
    文本.添加 (“第” + 到文本 (i) + “名:” + 国家 + “(” + 代号 + “)” + #换行符)
    文本.添加 (“金牌/银牌/铜牌:” + 金牌 + “/” + 银牌 + “/” + 铜牌 + #换行符)
    文本.添加 (“-----------” + #换行符)
.计次循环尾 ()
返回 (文本.取文本 (, ))



.版本 2
.支持库 commobj

.子程序 金牌榜, 文本型
.局部变量 Data, 文本型
.局部变量 Json, 类_json
.局部变量 文本, 快速文本对象
.局部变量 i, 整数型
.局部变量 金牌, 文本型
.局部变量 银牌, 文本型
.局部变量 铜牌, 文本型
.局部变量 总数, 文本型
.局部变量 国家, 文本型
.局部变量 代号, 文本型
.局部变量 局_网址, 文本型
.局部变量 局_方式, 整数型
.局部变量 ADD_协议头, 类_POST数据类
.局部变量 局_提交协议头, 文本型
.局部变量 局_结果, 字节集


局_网址 = “https://www.baidu.com/s?ie=utf-8 ... 1%E7%89%8C%E6%A6%9C
局_方式 = 0
ADD_协议头.添加 (“User-Agent”, “Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.87 Safari/537.36”)

局_提交协议头 = ADD_协议头.获取协议头数据 ()

局_结果 = 网页_访问_对象 (局_网址, 局_方式, , , , 局_提交协议头)

Data = 到文本 (编码_编码转换对象 (局_结果))

Data = 文本_取出中间文本 (Data, “}]}},”, “,{” + #引号 + “tempName” + #引号 + “:” + #引号)
Json.解析 (Data)
.计次循环首 (Json.成员数 (“tplData.dataList”), i)
    国家 = Json.取通用属性 (“tplData.dataList[” + 到文本 (i - 1) + “].name”)
    代号 = Json.取通用属性 (“tplData.dataList[” + 到文本 (i - 1) + “].countryAbbr”)
    金牌 = Json.取通用属性 (“tplData.dataList[” + 到文本 (i - 1) + “].gold”)
    银牌 = Json.取通用属性 (“tplData.dataList[” + 到文本 (i - 1) + “].silver”)
    铜牌 = Json.取通用属性 (“tplData.dataList[” + 到文本 (i - 1) + “].copper”)
    总数 = Json.取通用属性 (“tplData.dataList[” + 到文本 (i - 1) + “].count”)
    文本.添加 (“第” + 到文本 (i) + “名:” + 国家 + “(” + 代号 + “)” + #换行符)
    文本.添加 (“金牌/银牌/铜牌:” + 金牌 + “/” + 银牌 + “/” + 铜牌 + #换行符)
    文本.添加 (“-----------” + #换行符)
.计次循环尾 ()
返回 (文本.取文本 (, ))





顺带附个交流群:点击链接加入群聊【如何优雅的玩转Robot】:https://jq.qq.com/?_wv=1027&k=lFHPJp00

回复 关闭延时

使用道具 举报

库伊拉 发表于 2021-8-15 23:20:49 | 显示全部楼层
大佬的沙发~
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

Qhyl 发表于 2021-8-16 00:27:19 | 显示全部楼层
啊这,这不是人家东京说了算吗?你这排行榜没意义啊/滑稽
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

小陈同学

18

主题

209

帖子

431

积分

超级版主

Rank: 8Rank: 8

积分
431
QQ

|Archiver|手机版|小栗子机器人社区 ( 琼ICP备2020005018号-14 )|网站地图

Powered by Discuz! X3.4 © 2001-2018 Comsenz Inc.