壹盾安全Cdn,小栗子论坛都在使用的Cdn
10核32G挂机宝5元|低价服务器|代理更优惠|自主研发|
【推荐】 SUB·优质插件 目录导航点击留言举报社区广告(周末处理)

求一个取群列表到超级列表框的例子

[复制链接]
查看: 134   回复: 1
245679a 发表于 2021-8-3 14:40:03 | 显示全部楼层 |阅读模式
求一个取群列表到超级列表框的例子
小栗子社区文字广告位 联系===》QQ1917703871
回复 关闭延时

使用道具 举报

白井黑子 发表于 2021-8-3 14:44:06 | 显示全部楼层
.版本 2
.支持库 iext

.子程序 _按钮1_被单击
.局部变量 群, 群信息, , "0"
.局部变量 群个数, 整数型
.局部变量 a, 整数型
.局部变量 群开关, 文本型
.局部变量 群主人, 文本型
.局部变量 sz超管, 文本型, , "0"
.局部变量 b, 整数型
.局部变量 QQ, 文本型
.局部变量 群超管, 文本型

超级列表框1.全部删除 ()
Api.取群列表 (kj, 群)

群个数 = 取数组成员数 (群)

.计次循环首 (群个数, a)
    超级列表框1.插入表项 (a - 1, , , , , )
    超级列表框1.置标题 (a - 1, 0, 到文本 (a))
    超级列表框1.置标题 (a - 1, 1, 到文本 (群 [a].群号) + “【” + 群 [a].群名称 + “】”)
    群主人 = 读配置项 (dirs + 到文本 (群 [a].群号) + “配置.ini”, “基础配置”, “主人QQ”, )
    超级列表框1.置标题 (a - 1, 2, 群主人)
    群超管 = 读配置项 (dirs + 到文本 (群 [a].群号) + “配置.ini”, “基础配置”, “超管QQ”, )
    sz超管 = 分割文本 (群超管, “#”, )
    .计次循环首 (取数组成员数 (sz超管), b)
        QQ = sz超管
        超级列表框1.置标题 (a - 1, 3, 超级列表框1.取标题 (3, a) + QQ)
    .计次循环尾 ()
    群开关 = 读群 (到文本 (群 [a].群号), “基础配置”, “开关”)
    超级列表框1.置标题 (a - 1, 4, 群开关)
.计次循环尾 ()
.版本 2
.支持库 iext

.子程序 _按钮1_被单击
.局部变量 群, 群信息, , "0"
.局部变量 群个数, 整数型
.局部变量 a, 整数型
.局部变量 群开关, 文本型
.局部变量 群主人, 文本型
.局部变量 sz超管, 文本型, , "0"
.局部变量 b, 整数型
.局部变量 QQ, 文本型
.局部变量 群超管, 文本型

超级列表框1.全部删除 ()
Api.取群列表 (kj, 群)

群个数 = 取数组成员数 (群)

.计次循环首 (群个数, a)
    超级列表框1.插入表项 (a - 1, , , , , )
    超级列表框1.置标题 (a - 1, 0, 到文本 (a))
    超级列表框1.置标题 (a - 1, 1, 到文本 (群 [a].群号) + “【” + 群 [a].群名称 + “】”)
    群主人 = 读配置项 (dirs + 到文本 (群 [a].群号) + “配置.ini”, “基础配置”, “主人QQ”, )
    超级列表框1.置标题 (a - 1, 2, 群主人)
    群超管 = 读配置项 (dirs + 到文本 (群 [a].群号) + “配置.ini”, “基础配置”, “超管QQ”, )
    sz超管 = 分割文本 (群超管, “#”, )
    .计次循环首 (取数组成员数 (sz超管), b)
        QQ = sz超管
        超级列表框1.置标题 (a - 1, 3, 超级列表框1.取标题 (3, a) + QQ)
    .计次循环尾 ()
    群开关 = 读群 (到文本 (群 [a].群号), “基础配置”, “开关”)
    超级列表框1.置标题 (a - 1, 4, 群开关)
.计次循环尾 ()


是我一个分群开关的栗子,你可以研究研究,希望能帮到你
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

245679a

11

主题

52

帖子

162

积分

新手上路

Rank: 1

积分
162

|Archiver|手机版|小栗子机器人社区 ( 琼ICP备2020005018号-14 )|网站地图

Powered by Discuz! X3.4 © 2001-2018 Comsenz Inc.