关于使用Api.取框架QQ的小技巧

[复制链接]
查看: 513   回复: 5
大白蚁 发表于 2020-8-14 00:35:21 | 显示全部楼层 |阅读模式
本帖最后由 大白蚁 于 2020-8-14 00:40 编辑

请教了群里的大神们,使用精易模块中的类_json 获取框架QQ号码,并且判断是否在线。


  1. .版本 2

  2. .子程序 演示子程序
  3. .局部变量 JSON, 类_json
  4. .局部变量 取框架账号, 文本型
  5. .局部变量 框架账号数组, 文本型, , "0"
  6. .局部变量 在线状态, 文本型, , , 登录完毕/未登录
  7. .局部变量 群信息数组, 群信息, , "0"


  8. 取框架账号 = Api.取框架QQ ()
  9. JSON.解析 (取框架账号)

  10. ' //这里是将QQ账号取出来放置在框架账号数组变量中,可能前后顺序有所不同,看自己的精易模块提示吧!
  11. JSON.取所有属性名 (框架账号数组, “QQlist”)

  12. ' //下面可以使用计次循环依次取出状态、昵称,但这里就不演示了。
  13. ' //取出第一个账号的登录状态
  14. 在线状态 = JSON.取通用属性 (“QQlist[” + 框架账号数组 [1] + “].登录状态”)

  15. ' //下一步就可以用来取出想要的信息了,比如群列表
  16. Api.取群列表 (到长整数 (框架账号数组 [1]), 群信息数组)

复制代码

表演代码截图





本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复 关闭延时

使用道具 举报

柒彦彦 发表于 2020-8-14 02:12:58 | 显示全部楼层
感谢楼主分享教程
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

13只shmily 发表于 2020-8-14 02:17:50 | 显示全部楼层
学习了。。。谢谢!
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

fuxi 发表于 2020-8-14 13:56:29 | 显示全部楼层
啥也不说了,楼主就是给力!
解决不了问题,那就解决提出问题的人
回复

使用道具 举报

幻想キラー 发表于 2020-8-15 11:16:24 | 显示全部楼层
果断回帖,如果沉了就是我弄沉的很有成就感
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

qingyan 发表于 2020-9-1 09:34:59 | 显示全部楼层
感谢楼主分享教程
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

大白蚁

楼主

|Archiver|手机版|小黑屋|小栗子机器人社区

Powered by 小栗子机器人社区 X3.4 © 2001-2020 Comsenz Inc.