挂机宝低至5元一个月、免费试用5小时挂机宝低至5元一个月、免费试用5小时挂机宝低至5元一个月、免费试用5小时群监控/群管/拉人/ 全网各种插件聚集地
云骏数据|主营海外VPS|香港2c4g19.9|招收代理|特惠挂机宝
三网话费95折|特惠电影票|在线选座燃鹅白嫖交友群:119705222【推荐】 SUB·优质插件 目录导航
特爱易支付|三网收量|安全稳定|费率美丽
【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙等【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙等【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙
【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙点击留言举报社区广告(周末处理)小栗子广告位招租 记者勿扰小栗子广告位招租 记者勿扰

大佬们有没有一个自动撤回的插件

[复制链接]
查看: 81   回复: 2
DH9548 发表于 2021-6-9 10:23:27 | 显示全部楼层 |阅读模式
大佬们有没有一个可以让机器人发出信息后半分钟自动撤回的插件啊

小栗子社区文字广告位 联系===》QQ1917703871
回复 关闭延时

使用道具 举报

lgc2333 发表于 2021-6-9 12:17:41 | 显示全部楼层
.版本 2
.支持库 spec
.支持库 EThread
.程序集变量 enable, 逻辑型

.子程序 收到私聊消息, 整数型, , !!!本函数运行环境为【多线程】!!!1后面的插件不再处理此消息,0后面的插件仍可处理此消息
.参数 数据指针, 整数型
.局部变量 数据, 私聊消息数据

' 请勿在此执行上传文件之类的耗时操作,此类操作请另开线程执行
读取私聊消息数据 (数据指针, 数据)
' 自己在其他设备向别人发送消息时:数据.来源事件QQ 为收信QQ   数据.来源事件QQ昵称 为收信QQ昵称


' 分片消息也将传入插件,方便进行撤回消息,如果你不需要分片消息,可以过滤掉分片消息

' 当你的插件需要弹框时,请在信息框标题注明这个弹框来自于哪个插件,以免对用户造成困扰

' 当你未使用框架发送过匿名消息时,其他设备发送匿名消息,数据.框架QQ匿名Id=0,此时,可以使用API【强制取自身匿名Id】解决问题

.如果真 (数据.发送人QQ = 数据.框架QQ)  ' 过滤自己(包括其他设备)的消息,你也可以不过滤
    启动线程_文本 (&撤回线程, “0,” + 到文本 (数据.框架QQ) + “,” + 到文本 (数据.发送人QQ) + “,” + 到文本 (数据.消息Random) + “,” + 到文本 (数据.消息Req) + “,” + 到文本 (数据.消息接收时间))
.如果真结束
返回 (#消息处理_忽略)

.子程序 收到群消息, 整数型, , !!!本函数运行环境为【多线程】!!!1后面的插件不再处理此消息,0后面的插件仍可处理此消息
.参数 数据指针, 整数型
.局部变量 数据, 群消息数据

' 请勿在此执行上传文件之类的耗时操作,此类操作请另开线程执行
读取群消息数据 (数据指针, 数据)


' 分片消息也将传入插件,方便进行撤回消息,如果你不需要分片消息,可以过滤掉分片消息

' 当你的插件需要弹框时,请在信息框标题注明这个弹框来自于哪个插件,以免对用户造成困扰

' 当你未使用框架发送过匿名消息时,其他设备发送匿名消息,数据.框架QQ匿名Id=0,此时,可以使用API【强制取自身匿名Id】解决问题

.如果真 (数据.发送人QQ ≠ 数据.框架QQ 且 数据.发送人QQ ≠ 数据.框架QQ匿名Id)  ' 过滤自己(包括其他设备)的消息,你也可以不过滤
    ' 在付费版本当中,真正的红包等将传入文本代码,直接发送红包等的代码将被框架转义,再传入,所以不用担心安全问题
    .判断开始 (数据.消息类型 = #消息类型_讨论组消息)
        启动线程_文本 (&撤回线程, “2,” + 到文本 (数据.框架QQ) + “,” + 到文本 (数据.消息群号) + “,” + 到文本 (数据.消息Random) + “,” + 到文本 (数据.消息Req))
    .默认
        启动线程_文本 (&撤回线程, “1,” + 到文本 (数据.框架QQ) + “,” + 到文本 (数据.消息群号) + “,” + 到文本 (数据.消息Random) + “,” + 到文本 (数据.消息Req))
    .判断结束

.如果真结束

返回 (#消息处理_忽略)

.子程序 被启用

enable = 真

.子程序 被禁用

enable = 假

.子程序 撤回线程
.参数 info, 文本型
.局部变量 data, 文本型, , "0"

.计次循环首 (300, )
    .如果真 (enable = 假)
        跳出循环 ()
    .如果真结束
    延时 (100)  ' 100*300=30,000
.计次循环尾 ()
.如果真 (enable)
    data = 分割文本 (info, , )
    .判断开始 (data [1] = “0”)  ' private
        Api.撤回消息_私聊本身 (到长整数 (data [2]), 到长整数 (data [3]), 到长整数 (data [4]), 到整数 (data [5]), 到整数 (data [6]))
    .判断 (data [1] = “1”)  ' group
        Api.撤回消息_群聊 (到长整数 (data [2]), 到长整数 (data [3]), 到长整数 (data [4]), 到整数 (data [5]))
    .判断 (data [1] = “2”)  ' discuss
        Api.撤回消息_讨论组 (到长整数 (data [2]), 到长整数 (data [3]), 到长整数 (data [4]), 到整数 (data [5]))
    .默认

    .判断结束

.如果真结束


.子程序 启动线程_文本, 逻辑型
.参数 子程序, 子程序指针
.参数 文本参数, 文本型
.局部变量 传递地址, 整数型

传递地址 = 申请内存 (取文本长度 (文本参数) + 1, 真)
写到内存 (到字节集 (文本参数), 传递地址, )
返回 (启动线程 (子程序, 传递地址, ))

.版本 2
.支持库 spec
.支持库 EThread
.程序集变量 enable, 逻辑型

.子程序 收到私聊消息, 整数型, , !!!本函数运行环境为【多线程】!!!1后面的插件不再处理此消息,0后面的插件仍可处理此消息
.参数 数据指针, 整数型
.局部变量 数据, 私聊消息数据

' 请勿在此执行上传文件之类的耗时操作,此类操作请另开线程执行
读取私聊消息数据 (数据指针, 数据)
' 自己在其他设备向别人发送消息时:数据.来源事件QQ 为收信QQ   数据.来源事件QQ昵称 为收信QQ昵称


' 分片消息也将传入插件,方便进行撤回消息,如果你不需要分片消息,可以过滤掉分片消息

' 当你的插件需要弹框时,请在信息框标题注明这个弹框来自于哪个插件,以免对用户造成困扰

' 当你未使用框架发送过匿名消息时,其他设备发送匿名消息,数据.框架QQ匿名Id=0,此时,可以使用API【强制取自身匿名Id】解决问题

.如果真 (数据.发送人QQ = 数据.框架QQ)  ' 过滤自己(包括其他设备)的消息,你也可以不过滤
    启动线程_文本 (&撤回线程, “0,” + 到文本 (数据.框架QQ) + “,” + 到文本 (数据.发送人QQ) + “,” + 到文本 (数据.消息Random) + “,” + 到文本 (数据.消息Req) + “,” + 到文本 (数据.消息接收时间))
.如果真结束
返回 (#消息处理_忽略)

.子程序 收到群消息, 整数型, , !!!本函数运行环境为【多线程】!!!1后面的插件不再处理此消息,0后面的插件仍可处理此消息
.参数 数据指针, 整数型
.局部变量 数据, 群消息数据

' 请勿在此执行上传文件之类的耗时操作,此类操作请另开线程执行
读取群消息数据 (数据指针, 数据)


' 分片消息也将传入插件,方便进行撤回消息,如果你不需要分片消息,可以过滤掉分片消息

' 当你的插件需要弹框时,请在信息框标题注明这个弹框来自于哪个插件,以免对用户造成困扰

' 当你未使用框架发送过匿名消息时,其他设备发送匿名消息,数据.框架QQ匿名Id=0,此时,可以使用API【强制取自身匿名Id】解决问题

.如果真 (数据.发送人QQ ≠ 数据.框架QQ 且 数据.发送人QQ ≠ 数据.框架QQ匿名Id)  ' 过滤自己(包括其他设备)的消息,你也可以不过滤
    ' 在付费版本当中,真正的红包等将传入文本代码,直接发送红包等的代码将被框架转义,再传入,所以不用担心安全问题
    .判断开始 (数据.消息类型 = #消息类型_讨论组消息)
        启动线程_文本 (&撤回线程, “2,” + 到文本 (数据.框架QQ) + “,” + 到文本 (数据.消息群号) + “,” + 到文本 (数据.消息Random) + “,” + 到文本 (数据.消息Req))
    .默认
        启动线程_文本 (&撤回线程, “1,” + 到文本 (数据.框架QQ) + “,” + 到文本 (数据.消息群号) + “,” + 到文本 (数据.消息Random) + “,” + 到文本 (数据.消息Req))
    .判断结束

.如果真结束

返回 (#消息处理_忽略)

.子程序 被启用

enable = 真

.子程序 被禁用

enable = 假

.子程序 撤回线程
.参数 info, 文本型
.局部变量 data, 文本型, , "0"

.计次循环首 (300, )
    .如果真 (enable = 假)
        跳出循环 ()
    .如果真结束
    延时 (100)  ' 100*300=30,000
.计次循环尾 ()
.如果真 (enable)
    data = 分割文本 (info, , )
    .判断开始 (data [1] = “0”)  ' private
        Api.撤回消息_私聊本身 (到长整数 (data [2]), 到长整数 (data [3]), 到长整数 (data [4]), 到整数 (data [5]), 到整数 (data [6]))
    .判断 (data [1] = “1”)  ' group
        Api.撤回消息_群聊 (到长整数 (data [2]), 到长整数 (data [3]), 到长整数 (data [4]), 到整数 (data [5]))
    .判断 (data [1] = “2”)  ' discuss
        Api.撤回消息_讨论组 (到长整数 (data [2]), 到长整数 (data [3]), 到长整数 (data [4]), 到整数 (data [5]))
    .默认

    .判断结束

.如果真结束


.子程序 启动线程_文本, 逻辑型
.参数 子程序, 子程序指针
.参数 文本参数, 文本型
.局部变量 传递地址, 整数型

传递地址 = 申请内存 (取文本长度 (文本参数) + 1, 真)
写到内存 (到字节集 (文本参数), 传递地址, )
返回 (启动线程 (子程序, 传递地址, ))


源码和插件稍后上传
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

lgc2333 发表于 2021-6-9 12:20:38 | 显示全部楼层
https://stu2333.lanzoui.com/ia3dTpz4q4j

另外可以看看我的其他插件 感谢支持~
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

DH9548

楼主

|Archiver|手机版|小黑屋|小栗子机器人社区 ( 琼ICP备2020005018号-14 )|网站地图

Powered by Discuz! X3.4 © 2001-2018 Comsenz Inc.