小栗子机器人如何取登录QQ信息,新手来看

[复制链接]
查看: 974   回复: 15
骑士学长 发表于 2020-8-13 17:05:25 | 显示全部楼层 |阅读模式
本帖最后由 骑士学长 于 2020-8-13 17:10 编辑

这里举个例子,其实取了QQ出来再取其他的你们都方便操作,适合新手看,老手看了会吐,也有人会觉得多此一举

小栗子主程序集需要写到(因为你写到窗口程序,是没有info这个东西的,因为要取QQ和昵称所以要申请权限)


  1. .版本 2

  2. info.置应用权限申请 (#权限_取框架QQ, “信息用”)
  3. info.置应用权限申请 (#权限_取昵称_从缓存, “取昵称”)
复制代码
然后我们绘制一个图片框(放机器人头像用)在还有两个透明标签(这块我就取QQ和网名)


窗口程序需要写的内容

  1. .版本 2
  2. .支持库 internet
  3. .支持库 iext

  4. .程序集 窗口程序集_窗口1

  5. .子程序 _窗口1_创建完毕

  6. 机器人信息 ()


  7. .子程序 机器人信息
  8. .局部变量 机器人QQ, 文本型
  9. .局部变量 机器人name, 文本型

  10. 机器人QQ = 到文本 (文本_取出中间文本 (Api.取框架QQ (), #QQ前, #QQ后))
  11. 图片框_机器人头像.图片 = HTTP读文件 (“http://q1.qlogo.cn/g?b=qq&nk=” + 机器人QQ + “&s=640”)
  12. 机器人name = Api.取昵称_从缓存 (机器人QQ)
  13. 透明标签_机器人网名.标题 = 机器人name
  14. 透明标签_机器人QQ.标题 = 机器人QQ
复制代码
  1. 变量:

  2. QQ前:{"QQlist":{"
  3. QQ后:":{"昵称":"
复制代码



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复 关闭延时

使用道具 举报

柒彦彦 发表于 2020-8-13 17:15:27 | 显示全部楼层
谢谢楼主教程 前排来支持一下
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

抹茶味小油桃 发表于 2020-8-13 17:33:29 | 显示全部楼层
感谢大佬的教程
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

 楼主| 骑士学长 发表于 2020-8-13 19:49:06 | 显示全部楼层
柒彦彦 发表于 2020-8-13 17:15
谢谢楼主教程 前排来支持一下

有人看就不错了
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

柒彦彦 发表于 2020-8-13 19:59:21 | 显示全部楼层

hhh 肯定有的
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

珉朝 发表于 2020-8-13 20:07:05 | 显示全部楼层
感谢感谢
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

qwqqwq 发表于 2020-8-14 01:06:36 | 显示全部楼层
虽然不懂但是我会好好看完的,所以怎么用???
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

 楼主| 骑士学长 发表于 2020-8-14 10:35:18 | 显示全部楼层
qwqqwq 发表于 2020-8-14 01:06
虽然不懂但是我会好好看完的,所以怎么用???

你写机器人就知道了
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

396000318 发表于 2020-8-17 14:47:42 | 显示全部楼层
本帖最后由 396000318 于 2020-8-17 14:56 编辑

支持支持
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

发财了哦 发表于 2020-8-18 00:06:08 | 显示全部楼层
如果多个呢?这样就不行了啊
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

12下一页
您需要登录后才可以回帖   登录 立即注册

高级模式

|Archiver|手机版|小黑屋|小栗子机器人社区

Powered by 小栗子机器人社区 X3.4 © 2001-2020 Comsenz Inc.