怎么获取登录的QQ群列表

[复制链接]
查看: 73   回复: 4
puqiang 发表于 2020-8-13 12:41:15 | 显示全部楼层 |阅读模式
怎么获取登录的QQ群列表
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复 关闭延时

使用道具 举报

少白 发表于 2020-8-13 15:05:37 | 显示全部楼层
本帖最后由 少白 于 2020-8-13 15:19 编辑
  1. .版本 2

  2. .子程序 取QQ, 长整数型, , 直接返回框架QQ列表第一个QQ
  3. .参数 QQ, 长整数型, 可空 数组, 如果有多个QQ 即以数组形式返回
  4. .局部变量 json, 类_json
  5. .局部变量 QQ_, 文本型
  6. .局部变量 Q, 文本型
  7. .局部变量 i, 整数型

  8. QQ_ = Api.取框架QQ ()
  9. json.解析 (QQ_)
  10. json.取所有属性名 (Q, “QQlist”)
  11. .计次循环首 (取数组成员数 (Q), i)
  12.     加入成员 (QQ, 到长整数 (Q [i]))
  13. .计次循环尾 ()
  14. 返回 (QQ [1])
复制代码
  1. .版本 2
  2. .支持库 iext

  3. .子程序 刷新群列表
  4. .局部变量 群列表, 群信息
  5. .局部变量 i, 整数型
  6. .局部变量 群号, 文本型
  7. .局部变量 群名, 文本型
  8. .局部变量 sy
  9. .局部变量 QQ, 长整数型, , "0"
  10. .局部变量 计次, 整数型

  11. 取QQ (QQ)
  12. .计次循环首 (取数组成员数 (QQ), 计次)
  13.     Api.取群列表 (QQ [计次], 群列表)
  14.     .计次循环首 (取数组成员数 (群列表), i)
  15.         群号 = 群列表 [i].GroupCode
  16.         群名 = 群列表 [i].strGroupName
  17.         sy = 超级列表框1.插入表项 (, , , , , )
  18.         超级列表框1.置标题 (sy, 0, 群名)
  19.         超级列表框1.置标题 (sy, 1, 群号)
  20.     .计次循环尾 ()
  21. .计次循环尾 ()
复制代码

小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

 楼主| puqiang 发表于 2020-8-13 15:32:57 | 显示全部楼层

错误(34): 找不到指定的对象成员名称“GroupCode”。
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

Abyss_Reg 发表于 2020-8-13 21:25:29 | 显示全部楼层
puqiang 发表于 2020-8-13 15:32
错误(34): 找不到指定的对象成员名称“GroupCode”。

你的sdk是什么版本的
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

Abyss_Reg 发表于 2020-8-13 21:27:18 | 显示全部楼层
puqiang 发表于 2020-8-13 15:32
错误(34): 找不到指定的对象成员名称“GroupCode”。

如果是新版sdk,那么尝试把GroupCode换成群号,strGroupName换成群名试试看,他给出的是sdk2.5.8的代码,sdk有升级,所以不一样
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

puqiang

楼主

|Archiver|手机版|小黑屋|小栗子机器人社区

Powered by 小栗子机器人社区 X3.4 © 2001-2020 Comsenz Inc.