挂机宝低至5元一个月、免费试用5小时挂机宝低至5元一个月、免费试用5小时挂机宝低至5元一个月、免费试用5小时群监控/群管/拉人/ 全网各种插件聚集地
10核32G挂机宝5元|低价服务器|代理更优惠|自主研发|
三网话费95折|特惠电影票|在线选座燃鹅白嫖交友群:119705222【推荐】 SUB·优质插件 目录导航【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙等【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙等
【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙点击留言举报社区广告(周末处理)  

怎么写文字转图片,大佬们

[复制链接]
查看: 272   回复: 1
qyixj 发表于 2021-5-10 01:32:40 | 显示全部楼层 |阅读模式
21栗子

如标题
小栗子社区文字广告位 联系===》QQ1917703871
回复 关闭延时

使用道具 举报

小陈同学 发表于 2021-5-10 08:15:13 | 显示全部楼层
.版本 2

.子程序 DIY图片_添加文字, 字节集
.参数 参数_文本内容, 文本型
.参数 宽度, 整数型
.参数 高度, 整数型
.参数 参数_左边, 整数型
.参数 参数_顶边, 整数型
.参数 参数_字体, 文本型
.参数 参数_字体大小, 整数型
.参数 参数_字体颜色, 整数型
.局部变量 位图, GP位图
.局部变量 图形, GP图形
.局部变量 字体, GP字体
.局部变量 画刷, GP纯色画刷
.局部变量 文本格式, GP文本格式
.局部变量 返回图片, 字节集

' ’位图.创建自字节集 (参数_图片, )
位图.创建自像素格式 (宽度, 高度)
图形.创建自图像 (位图)
字体.创建自名称 (参数_字体, 30, #字体风格_普通, )
画刷.创建 (RGB到ARGB (参数_字体颜色, ))
文本格式.创建 (#文本格式标志_不换行, )
文本格式.置对齐 (#文本对齐_靠近)
图形.画文本 (参数_文本内容, 字体, 画刷, 制矩形F (参数_左边, 参数_顶边, 位图.取宽度 (), 位图.取高度 ()), 文本格式)
返回图片 = 位图.保存到字节集 (#图像格式_PNG, )
位图.销毁 ()
图形.销毁 ()
字体.销毁 ()
画刷.销毁 ()
文本格式.销毁 ()
返回 (返回图片)
回复

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

qyixj

楼主

|Archiver|手机版|小黑屋|小栗子机器人社区 ( 琼ICP备2020005018号-14 )|网站地图

Powered by Discuz! X3.4 © 2001-2018 Comsenz Inc.