壹盾安全Cdn,小栗子论坛都在使用的Cdn
10核32G挂机宝5元|低价服务器|代理更优惠|自主研发|
【推荐】 SUB·优质插件 目录导航点击留言举报社区广告(周末处理)

插件请求:通过指令关闭电脑程序再次打开运行的插件

[复制链接]
查看: 215   回复: 3
wager 发表于 2021-4-24 22:58:03 | 显示全部楼层 |阅读模式
1栗子
有没有办法可以设置一个指定关闭某个程序,然后再打开启动的插件?

最佳答案

查看完整内容

.版本 2 .支持库 shell .局部变量 框架编号, 文本型 .局部变量 插件位置, 文本型 .局部变量 框架位置, 文本型 .局部变量 结果, 逻辑型 .局部变量 进程ID, 整数型 框架编号 = 读配置项 (取运行目录 () + “\小陈同学Bot\系统设置.ini”, “更新设置”, “框架编号”, ) 框架位置 = 读配置项 (取运行目录 () + “\小陈同学Bot\系统设置.ini”, “更新设置”, “框架路径”, ) 进程ID = 到整数 (读配置项 (取运行目录 () + “ ...
小栗子社区文字广告位 联系===》QQ1917703871
回复 关闭延时

使用道具 举报

小陈同学 发表于 2021-4-24 22:58:04 | 显示全部楼层
.版本 2
.支持库 shell

.局部变量 框架编号, 文本型
.局部变量 插件位置, 文本型
.局部变量 框架位置, 文本型
.局部变量 结果, 逻辑型
.局部变量 进程ID, 整数型

框架编号 = 读配置项 (取运行目录 () + “\小陈同学Bot\系统设置.ini”, “更新设置”, “框架编号”, )
框架位置 = 读配置项 (取运行目录 () + “\小陈同学Bot\系统设置.ini”, “更新设置”, “框架路径”, )
进程ID = 到整数 (读配置项 (取运行目录 () + “\小陈同学Bot\系统设置.ini”, “更新设置”, “进程ID”, ))

结果 = 进程_结束 (进程ID)
.判断开始 (框架编号 = “0”)
    插件位置 = 取运行目录 () + “\main\plugin\小陈同学.dll”
.判断 (框架编号 = “1” 或 框架编号 = “2” 或 框架编号 = “3”)
    插件位置 = 取运行目录 () + “\Plugin\小陈同学.IR.dll”
.判断 (框架编号 = “4”)
    插件位置 = 取运行目录 () + “\plugin\小陈同学.dll”
.默认

.判断结束


文件_删除 (插件位置)
结果 = 写到文件 (插件位置, 网页_访问_对象 (“http://bot.lovetly.top/小陈同学.dll”))
.判断开始 (结果)
    执行 (4, 框架位置, , , )
    提示框 (“更新成功”, 33, “小陈同学提醒您”)
    结束 ()
.默认
    提示框 (“插件更新失败,可能是没有结束进程”, 33, “小陈同学提醒您”)
    结束 ()
.判断结束



这个是比较简单的方法
回复

使用道具 举报

远方 发表于 2021-4-25 00:15:00 | 显示全部楼层
可以定制599929114
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

小时光 发表于 2021-4-25 11:25:55 | 显示全部楼层
防守打法发生的
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

wager

1

主题

20

帖子

32

积分

新手上路

Rank: 1

积分
32

|Archiver|手机版|小栗子机器人社区 ( 琼ICP备2020005018号-14 )|网站地图

Powered by Discuz! X3.4 © 2001-2018 Comsenz Inc.