取群列表到超级列表框怎么弄呢,高手指点一下。

[复制链接]
查看: 64   回复: 1
jiandale 发表于 2020-8-9 09:47:59 | 显示全部楼层 |阅读模式
取群列表到超级列表框怎么弄呢,高手指点一下。.版本 2
.支持库 spec
.支持库 iext

.子程序 读取群列表
.局部变量 群, 群信息, , "0"
.局部变量 返回, 整数型
.局部变量 框架QQ集, 文本型
.局部变量 框架QQ号集, 文本型, , "0"
.局部变量 json, 类_json
.局部变量 局_计次, 整数型
.局部变量 局_计次2, 整数型

重定义数组 (框架QQ号集, 假, 0)
框架QQ集 = Api.取框架QQ ()
json.解析 (框架QQ集)
json.取属性 (“QQlist”).取所有属性名 (框架QQ号集)
.计次循环首 (取数组成员数 (框架QQ号集), 局_计次)
    调试输出 (框架QQ号集 [局_计次])
    返回 = Api.取群列表 (到长整数 (框架QQ号集 [局_计次]), 群)
    .计次循环首 (取数组成员数 (群), 局_计次2)
        超级列表框_群列表.置标题 (局_计次2 - 1, 1, 到文本 (群 [局_计次2].群号))
    .计次循环尾 ()
    信息框 (取数组成员数 (群), 0, , )

.计次循环尾 ()


能得到群数量,就是数组值为空

小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复 关闭延时

使用道具 举报

ycxy 发表于 2020-8-9 10:19:28 | 显示全部楼层
为啥不直接Api.取群列表(参数自己看),然后循环置标题
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

jiandale

楼主

|Archiver|手机版|小黑屋|小栗子机器人社区

Powered by 小栗子机器人社区 X3.4 © 2001-2020 Comsenz Inc.