挂机宝低至5元一个月、免费试用5小时挂机宝低至5元一个月、免费试用5小时挂机宝低至5元一个月、免费试用5小时群监控/群管/拉人/ 全网各种插件聚集地
10核32G挂机宝5元|低价服务器|代理更优惠|自主研发|
三网话费95折|特惠电影票|在线选座燃鹅白嫖交友群:119705222【推荐】 SUB·优质插件 目录导航
【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙等【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙等【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙
点击留言举报社区广告(周末处理)论坛日PV20000 IP1500
8月份优惠广告位招租 记者勿扰
论坛日PV20000 IP1500
8月份优惠广告位招租 记者勿扰
论坛日PV20000 IP1500
8月份优惠广告位招租 记者勿扰

au web api例子-智能聊天

[复制链接]
查看: 434   回复: 1
dannn 发表于 2021-1-14 20:20:57 | 显示全部楼层 |阅读模式

AU WEB API 智能聊天例子
需要AU WEB API支持-webapi下载地址https://bbs.xiaolz.cn/thread-1633-1-1.html
本例子源码:
.版本 2
.支持库 e2ee

.子程序 _启动子程序, 整数型, , 本子程序在程序启动后最先执行


start ()
返回 (0)  ' 可以根据您的需要返回任意数值

.子程序 输出
.参数 文本, 文本型

标准输出 (, 文本 + #换行符)


.子程序 code, 整数型
.局部变量 ja, _Json
.局部变量 JSON, 文本型

JSON = 到文本 (网页_访问S (ip + “/?pwd=” + 读配置项 (取运行目录 () + “\设置.ini”, “设置”, “key”, ), , , , , , , , , , , , , , , , , , , , ))
ja.解析 (JSON, )
.如果 (ja.取文本 (“code”) = “-1”)
    输出 (“key错误”)
    返回 (-1)
.否则
    .如果 (ja.取文本 (“code”) = “”)
        输出 (“ip/端口错误”)
        返回 (-1)
    .否则
        返回 (到整数 (ja.取文本 (“code”)))
    .如果结束

.如果结束
输出 (到文本 (ja.取文本 (“code”) = “-1”))
返回 (到整数 (ja.取文本 (“code”)))


.子程序 json项, 文本型
.参数 json, 文本型
.参数 项, 文本型
.局部变量 ja, _Json

ja.解析 (json, )
返回 (ja.取文本 (项))

.子程序 start
.局部变量 局_qq号码_数组, 文本型, , "0"
.局部变量 i, 整数型
.局部变量 JSON, 文本型
.局部变量 jsonab, 类_json
.局部变量 ja, _Json

输出 (“数据初始化中”)
.如果 (读配置项 (取运行目录 () + “\设置.ini”, “设置”, “ip”, ) = “”)
    载入 (窗口1, , 真)
.否则

.如果结束
.如果 (读配置项 (取运行目录 () + “\设置.ini”, “设置”, “端口”, ) = “”)
    载入 (窗口1, , 真)
.否则

.如果结束
ip = “http://” + 读配置项 (取运行目录 () + “\设置.ini”, “设置”, “ip”, ) + “:” + 读配置项 (取运行目录 () + “\设置.ini”, “设置”, “端口”, )
输出 (“ip:” + ip)
.如果 (code () = -1)
    输出 (“数据初始化失败”)
    信息框 (“数据初始化失败”, 0, , )
    载入 (窗口1, , 真)
    运行 (取运行目录 () + “\” + 取执行文件名 (), 假, )
    结束 ()
.否则

.如果结束
JSON = 到文本 (网页_访问S (ip + “/takeframeQQ/” + “?pwd=” + 读配置项 (取运行目录 () + “\设置.ini”, “设置”, “key”, ), , , , , , , , , , , , , , , , , , , , ))
输出 (json项 (JSON, “frameQQ”))
.如果 (jsonab.解析 (json项 (JSON, “frameQQ”)))
    jsonab.取所有属性名 (QQlist, “QQlist”)

.否则

.如果结束
输出 (“框架QQ加载完成,共” + 到文本 (取数组成员数 (QQlist)) + “个”)

输出 (“数据初始化OK”)
' 接到好友消息 (“2590615029”, “0”, “00”, “66”, “3414034955”, “....”)
消息接收 ()

.子程序 消息接收
.局部变量 JSON, 文本型

JSON = 到文本 (网页_访问S (ip + “/takenewfriendmsgid/” + “?pwd=” + 读配置项 (取运行目录 () + “\设置.ini”, “设置”, “key”, ), , , , , , , , , , , , , , , , , , , , ))
.判断循环首 (真)
    .如果真 (取反 (json项 (JSON, “req”) = json项 (到文本 (网页_访问S (ip + “/takenewfriendmsgid/” + “?pwd=” + 读配置项 (取运行目录 () + “\设置.ini”, “设置”, “key”, ), , , , , , , , , , , , , , , , , , , , )), “req”)))
        JSON = 到文本 (网页_访问S (ip + “/takenewfriendmsgid/” + “?pwd=” + 读配置项 (取运行目录 () + “\设置.ini”, “设置”, “key”, ), , , , , , , , , , , , , , , , , , , , ))
        接到好友消息 (json项 (JSON, “框架QQ”), json项 (JSON, “气泡id”), json项 (JSON, “req”), json项 (JSON, “req”), json项 (JSON, “发送人QQ”), json项 (JSON, “消息内容”))
        输出 (JSON)
    .如果真结束
    延时 (90)
.判断循环尾 ()

.子程序 接到好友消息
.参数 框架QQ, 文本型
.参数 气泡id, 文本型
.参数 req, 文本型
.参数 seq, 文本型
.参数 发送人QQ, 文本型
.参数 msg, 文本型
.局部变量 返回内容, 文本型
.局部变量 j, _Json

返回内容 = UTF8到文本 (到字节集 (网页_访问S (“http://api.bystart.cn/api/chat?message=” + URL编码 (到文本 (文本到UTF8 (msg)), ), , , , , , , , , , , , , , , , , , , , )))
输出 (返回内容)
输出 (到文本 (网页_访问S (ip + “/sendfriendmsg/?pwd=” + 读配置项 (取运行目录 () + “\设置.ini”, “设置”, “key”, ) + “&框架QQ=” + 框架QQ + “&好友=” + 发送人QQ + “&内容=” + 编码_URL编码 (返回内容, , ), , , , , , , , , , , , , , , , , , , , )))


小栗子社区文字广告位 联系===》QQ1917703871
回复 关闭延时

使用道具 举报

 楼主| dannn 发表于 2021-7-12 10:06:29 | 显示全部楼层
......顶帖
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

dannn

楼主

|Archiver|手机版|小黑屋|小栗子机器人社区 ( 琼ICP备2020005018号-14 )|网站地图

Powered by Discuz! X3.4 © 2001-2018 Comsenz Inc.