挂机宝低至5元一个月、免费试用5小时挂机宝低至5元一个月、免费试用5小时挂机宝低至5元一个月、免费试用5小时群监控/群管/拉人/ 全网各种插件聚集地
云骏数据|主营海外VPS|香港2c4g19.9|招收代理|特惠挂机宝
三网话费95折|特惠电影票|在线选座燃鹅白嫖交友群:119705222【推荐】 SUB·优质插件 目录导航
特爱易支付|三网收量|安全稳定|费率美丽
【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙等【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙等【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙
【莆田鞋】|莆田本地直发|一手鞋源|一件代发|货到付款|V+SYingCms|匡威AJ马卡龙点击留言举报社区广告(周末处理)小栗子广告位招租 记者勿扰小栗子广告位招租 记者勿扰

2020.1.7:框架多Q操作强制取昵称问题

[复制链接]
查看: 479   回复: 10
dannn 发表于 2021-1-7 10:51:28 | 显示全部楼层 |阅读模式
本帖最后由 dannn 于 2021-1-7 22:36 编辑

测试环境:win10 预览版 20H4 build21277.1000
框架版本:2.8.8.2(2020.1.7最新)
出现问题:api.强制取昵称(,)
问题描述:多Q操作中强制取昵称时出现访问错误内存
框架共两个且登录完成的框架QQ
用第一个获取第二个的昵称或第二个获取第一个的昵称会发生错误
但时用第一个取第一个或第二个取第二个不会发生出错误

解决办法.版本 2


j.解析 (Api.取框架QQ ())
j.取所有属性名 (局_qq号_数组, “QQlist”)
.计次循环首 (取数组成员数 (局_qq号_数组), i)
    组合框4.加入项目 (Api.强制取昵称 (到长整数 (局_qq号_数组 ), 局_qq号_数组 ) + “(” + 局_qq号_数组 + “)”, )
.计次循环尾 ()
加入成员 (局_qq号_数组, “10001”)

小栗子社区文字广告位 联系===》QQ1917703871
回复 关闭延时

使用道具 举报

爱汇特帅 发表于 2021-1-7 16:39:45 | 显示全部楼层
局_qq号_数组  改成 局_qq号_数组 [i]
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

爱汇特帅 发表于 2021-1-7 16:41:14 | 显示全部楼层
.计次循环首 (取数组成员数 (局_qq号_数组), i)
    组合框4.加入项目 (Api.强制取昵称 (到长整数 (局_qq号_数组[i] ), 局_qq号_数组[i] ) + “(” + 局_qq号_数组[i] + “)”, )
.计次循环尾 ()

局_qq号_数组[i] 文本数组型
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

993 发表于 2021-1-7 17:53:28 | 显示全部楼层
楼上正解
小栗子社区文字广告位 联系===》QQ1917703871
回复

使用道具 举报

 楼主| dannn 发表于 2021-1-7 22:39:03 | 显示全部楼层

非正解(上面数组错误只是笔误)
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

 楼主| dannn 发表于 2021-1-7 22:40:50 | 显示全部楼层
爱汇特帅 发表于 2021-1-7 16:41
.计次循环首 (取数组成员数 (局_qq号_数组), i)
    组合框4.加入项目 (Api.强制取昵称 (到长整数 (局_qq号 ...

数组问题只是个笔误,我指的错误是多Q操作(代码与开源板块的多Q操作的帖子一样)在贴中的这个版本会出错
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

 楼主| dannn 发表于 2021-1-7 22:41:35 | 显示全部楼层
爱汇特帅 发表于 2021-1-7 16:41
.计次循环首 (取数组成员数 (局_qq号_数组), i)
    组合框4.加入项目 (Api.强制取昵称 (到长整数 (局_qq号 ...

数组问题这个笔误可能是小栗子论坛的编辑器有一些问题
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

爱汇特帅 发表于 2021-1-8 13:08:59 | 显示全部楼层
dannn 发表于 2021-1-7 22:41
数组问题这个笔误可能是小栗子论坛的编辑器有一些问题

就是数组的问题
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

 楼主| dannn 发表于 2021-1-8 13:20:11 | 显示全部楼层

no no no。不是
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

爱汇特帅 发表于 2021-1-8 13:26:49 | 显示全部楼层

还不是? 我都懒得给你解答了
小栗子社区文字广告位 联系===》QQ1917703871
回复 支持 反对

使用道具 举报

12下一页
您需要登录后才可以回帖   登录 立即注册

高级模式

dannn

楼主

|Archiver|手机版|小黑屋|小栗子机器人社区 ( 琼ICP备2020005018号-14 )|网站地图

Powered by Discuz! X3.4 © 2001-2018 Comsenz Inc.