论坛易语言代码显示测试Test

[复制链接]
查看: 52   回复: 1
默淮 发表于 2020-8-7 18:43:51 | 显示全部楼层 |阅读模式
[ecode=3].版本 2
.支持库 internet

.子程序 收到群消息, 整数型, , 1后面的插件不再处理此消息,0后面的插件仍可处理此消息
.参数 数据指针, 整数型
.局部变量 数据, 群消息数据
.局部变量 链接, 字节集
.局部变量 pic, 文本型

' 请勿在此执行上传文件之类的耗时操作,此类操作请另开线程执行
读取群消息数据 (数据指针, 数据)
.判断开始 (数据.消息类型 = #消息类型_群红包)
    .判断开始 (数据.发送人QQ ≠ 数据.框架QQ)  ' 自己的消息,这里应该避免自己和自己聊天

    .默认

    .判断结束

.判断 (数据.消息类型 = #消息类型_群聊通常消息)
    .判断开始 (数据.发送人QQ ≠ 数据.框架QQ)  ' 自己的消息,这里应该避免自己和自己聊天

    .默认

    .判断结束
    .如果真 (数据.消息内容 = “签到”)
        .如果真 (读配置项 (Api.取插件数据目录 () + “设置.ini”, “签到设置”, 到文本 (数据.发送人QQ) + 到文本 (取月份 (取现行时间 ())) + 到文本 (取日 (取现行时间 ())), ) = “今日已签”)
            Api.发送群消息 (数据.框架QQ, 数据.消息群号, “[@” + 到文本 (数据.发送人QQ) + “]” + #换行符 + 读配置项 (Api.取插件数据目录 () + “设置.ini”, “签到设置”, “重复提示语”, ), )
        .如果真结束
        .如果真 (读配置项 (Api.取插件数据目录 () + “设置.ini”, “签到设置”, 到文本 (数据.发送人QQ) + 到文本 (取月份 (取现行时间 ())) + 到文本 (取日 (取现行时间 ())), ) ≠ “今日已签”)
            链接 = HTTP读文件 (读配置项 (Api.取插件数据目录 () + “设置.ini”, “签到设置”, “api图片地址”, ))
            pic = Api.上传群图片 (数据.框架QQ, 数据.消息群号, , 链接)
            写配置项 (Api.取插件数据目录 () + “设置.ini”, “签到设置”, 到文本 (数据.发送人QQ) + 到文本 (取月份 (取现行时间 ())) + 到文本 (取日 (取现行时间 ())), “今日已签”)
            Api.发送群消息 (数据.框架QQ, 数据.消息群号, “[@” + 到文本 (数据.发送人QQ) + “]” + #换行符 + 读配置项 (Api.取插件数据目录 () + “设置.ini”, “签到设置”, “签到提示语”, ) + #换行符 + pic, )

        .如果真结束

    .如果真结束
    .如果真 (数据.消息内容 = “打卡”)
        .如果真 (读配置项 (Api.取插件数据目录 () + “设置.ini”, “签到设置”, 到文本 (数据.发送人QQ) + 到文本 (取月份 (取现行时间 ())) + 到文本 (取日 (取现行时间 ())), ) = “今日已签”)
            Api.发送群消息 (数据.框架QQ, 数据.消息群号, “[@” + 到文本 (数据.发送人QQ) + “]” + #换行符 + 读配置项 (Api.取插件数据目录 () + “设置.ini”, “签到设置”, “重复提示语”, ), )
        .如果真结束
        .如果真 (读配置项 (Api.取插件数据目录 () + “设置.ini”, “签到设置”, 到文本 (数据.发送人QQ) + 到文本 (取月份 (取现行时间 ())) + 到文本 (取日 (取现行时间 ())), ) ≠ “今日已签”)
            链接 = HTTP读文件 (读配置项 (Api.取插件数据目录 () + “设置.ini”, “签到设置”, “api图片地址”, ))
            pic = Api.上传群图片 (数据.框架QQ, 数据.消息群号, , 链接)
            写配置项 (Api.取插件数据目录 () + “设置.ini”, “签到设置”, 到文本 (数据.发送人QQ) + 到文本 (取月份 (取现行时间 ())) + 到文本 (取日 (取现行时间 ())), “今日已签”)
            Api.发送群消息 (数据.框架QQ, 数据.消息群号, “[@” + 到文本 (数据.发送人QQ) + “]” + #换行符 + 读配置项 (Api.取插件数据目录 () + “设置.ini”, “签到设置”, “签到提示语”, ) + #换行符 + pic, )
        .如果真结束

    .如果真结束

.默认

.判断结束

返回 (#消息处理_忽略)  ' 普通消息默认允许后面的插件重复处理[/ecode]
Moh 小白一枚 日常修仙 常年不在
回复 关闭延时

使用道具 举报

 楼主| 默淮 发表于 2020-8-7 18:45:44 | 显示全部楼层
测试失败
Moh 小白一枚 日常修仙 常年不在
回复

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

默淮

楼主

|Archiver|手机版|小黑屋|小栗子机器人社区

Powered by 小栗子机器人社区 X3.4 © 2001-2020 Comsenz Inc.