卡密生成-希望大家能用到

[复制链接]
查看: 157   回复: 0
dannn 发表于 2020-11-1 17:34:44 | 显示全部楼层 |阅读模式
.版本 2
.支持库 spec
.支持库 eAPI

.程序集 程序集1

.子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

_临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
返回 (0)  ' 可以根据您的需要返回任意数值

.子程序 _临时子程序

调试输出 (解析机器码 (获取机器码 ()))

.子程序 获取机器码, 文本型, 公开
.局部变量 cpu, CPU信息
.局部变量 cpu1级缓存, 文本型
.局部变量 cpu时钟频率, 文本型
.局部变量 cpu数据宽度, 文本型
.局部变量 A, 文本型
.局部变量 b, 字节集
.局部变量 系统类别, 文本型
.局部变量 c, 文本型

取CPU信息 (cpu)
cpu1级缓存 = 到文本 (cpu.一级缓存大小)
cpu时钟频率 = 到文本 (cpu.时钟频率)
cpu数据宽度 = 到文本 (cpu.数据宽度)
系统类别 = 到文本 (取操作系统类别 ())
A = cpu1级缓存 + cpu时钟频率 + cpu数据宽度 + 系统类别
调试输出 (A)
A = 文本_替换 (A, , , 假, “1”, “!!@@!@!@”, “a”, “^%112!';'$#”, “2”, “|?”, “3”, “%$@#¥%((*&&*()&”, “4”, “%&(&&%¥”)
A = 文本_替换 (A, , , 假, “5”, “QA!”, “6”, “^%-=#”, “7”, “|/\/”, “8”, “%$^$*()&”, “9”, “%%@#\¥”)
A = 字节集到十六进制文本 (到字节集 (A))
b = 文本到UTF8 (A)
A = 字节集到十六进制文本 (b)
调试输出 (A)
返回 (A)

.子程序 解析机器码, 文本型, 公开
.参数 文本, 文本型
.局部变量 A, 文本型
.局部变量 b, 字节集

b = 文本到字节集 (文本)
A = 到文本 (文本到字节集 (UTF8到文本 (b)))
A = 文本_替换 (A, , , 假, “!!@@!@!@”, “1”, “^%#¥@!!';'$#”, “a”, “|?”, “2”, “%$@#¥%((*&&*()&”, “3”, “%&(&&%¥”, “4”)
A = 文本_替换 (A, , , 假, “QA!”, “5”, “%-=#”, “^6”, “|/\/”, “7”, “%$^$*()&”, “8”, “%%@#\¥”, “9”)
返回 (A)

.子程序 文本到字节集, 字节集
.参数 文本, 文本型
.局部变量 高位, 文本型
.局部变量 低位, 文本型
.局部变量 高位数据, 整数型
.局部变量 低位数据, 整数型
.局部变量 数值, 整数型
.局部变量 文本数组, 文本型, , "0"
.局部变量 字节集, 字节集
.局部变量 次数, 整数型
.局部变量 计次, 整数型
.局部变量 数值数组, 字节型, , "0"

文本数组 = 分割文本 (文本, “ ”, )
次数 = 取数组成员数 (文本数组)
.计次循环首 (次数, 计次)
    高位 = 取文本左边 (文本数组 [计次], 1)
    低位 = 取文本右边 (文本数组 [计次], 1)

    .判断开始 (高位 = “A”)
        高位数据 = 10
    .判断 (高位 = “B”)
        高位数据 = 11
    .判断 (高位 = “C”)
        高位数据 = 12
    .判断 (高位 = “D”)
        高位数据 = 13
    .判断 (高位 = “E”)
        高位数据 = 14
    .判断 (高位 = “F”)
        高位数据 = 15
    .默认
        高位数据 = 到数值 (高位)
    .判断结束

    .判断开始 (低位 = “A”)
        低位数据 = 10
    .判断 (低位 = “B”)
        低位数据 = 11
    .判断 (低位 = “C”)
        低位数据 = 12
    .判断 (低位 = “D”)
        低位数据 = 13
    .判断 (低位 = “E”)
        低位数据 = 14
    .判断 (低位 = “F”)
        低位数据 = 15
    .默认
        低位数据 = 到数值 (低位)
    .判断结束

    数值 = 高位数据 × 16 + 低位数据
    加入成员 (数值数组, 到字节 (数值))
.计次循环尾 ()
字节集 = 到字节集 (数值数组)
返回 (字节集)
.版本 2
.支持库 spec
.支持库 eAPI

.程序集 程序集1

.子程序 _启动子程序, 整数型, , 请在本子程序中放置易模块初始化代码

_临时子程序 ()  ' 在初始化代码执行完毕后调用测试代码
返回 (0)  ' 可以根据您的需要返回任意数值

.子程序 _临时子程序

调试输出 (解析机器码 (获取机器码 ()))

.子程序 获取机器码, 文本型, 公开
.局部变量 cpu, CPU信息
.局部变量 cpu1级缓存, 文本型
.局部变量 cpu时钟频率, 文本型
.局部变量 cpu数据宽度, 文本型
.局部变量 A, 文本型
.局部变量 b, 字节集
.局部变量 系统类别, 文本型
.局部变量 c, 文本型

取CPU信息 (cpu)
cpu1级缓存 = 到文本 (cpu.一级缓存大小)
cpu时钟频率 = 到文本 (cpu.时钟频率)
cpu数据宽度 = 到文本 (cpu.数据宽度)
系统类别 = 到文本 (取操作系统类别 ())
A = cpu1级缓存 + cpu时钟频率 + cpu数据宽度 + 系统类别
调试输出 (A)
A = 文本_替换 (A, , , 假, “1”, “!!@@!@!@”, “a”, “^%112!';'$#”, “2”, “|?”, “3”, “%$@#¥%((*&&*()&”, “4”, “%&(&&%¥”)
A = 文本_替换 (A, , , 假, “5”, “QA!”, “6”, “^%-=#”, “7”, “|/\/”, “8”, “%$^$*()&”, “9”, “%%@#\¥”)
A = 字节集到十六进制文本 (到字节集 (A))
b = 文本到UTF8 (A)
A = 字节集到十六进制文本 (b)
调试输出 (A)
返回 (A)

.子程序 解析机器码, 文本型, 公开
.参数 文本, 文本型
.局部变量 A, 文本型
.局部变量 b, 字节集

b = 文本到字节集 (文本)
A = 到文本 (文本到字节集 (UTF8到文本 (b)))
A = 文本_替换 (A, , , 假, “!!@@!@!@”, “1”, “^%#¥@!!';'$#”, “a”, “|?”, “2”, “%$@#¥%((*&&*()&”, “3”, “%&(&&%¥”, “4”)
A = 文本_替换 (A, , , 假, “QA!”, “5”, “%-=#”, “^6”, “|/\/”, “7”, “%$^$*()&”, “8”, “%%@#\¥”, “9”)
返回 (A)

.子程序 文本到字节集, 字节集
.参数 文本, 文本型
.局部变量 高位, 文本型
.局部变量 低位, 文本型
.局部变量 高位数据, 整数型
.局部变量 低位数据, 整数型
.局部变量 数值, 整数型
.局部变量 文本数组, 文本型, , "0"
.局部变量 字节集, 字节集
.局部变量 次数, 整数型
.局部变量 计次, 整数型
.局部变量 数值数组, 字节型, , "0"

文本数组 = 分割文本 (文本, “ ”, )
次数 = 取数组成员数 (文本数组)
.计次循环首 (次数, 计次)
    高位 = 取文本左边 (文本数组 [计次], 1)
    低位 = 取文本右边 (文本数组 [计次], 1)

    .判断开始 (高位 = “A”)
        高位数据 = 10
    .判断 (高位 = “B”)
        高位数据 = 11
    .判断 (高位 = “C”)
        高位数据 = 12
    .判断 (高位 = “D”)
        高位数据 = 13
    .判断 (高位 = “E”)
        高位数据 = 14
    .判断 (高位 = “F”)
        高位数据 = 15
    .默认
        高位数据 = 到数值 (高位)
    .判断结束

    .判断开始 (低位 = “A”)
        低位数据 = 10
    .判断 (低位 = “B”)
        低位数据 = 11
    .判断 (低位 = “C”)
        低位数据 = 12
    .判断 (低位 = “D”)
        低位数据 = 13
    .判断 (低位 = “E”)
        低位数据 = 14
    .判断 (低位 = “F”)
        低位数据 = 15
    .默认
        低位数据 = 到数值 (低位)
    .判断结束

    数值 = 高位数据 × 16 + 低位数据
    加入成员 (数值数组, 到字节 (数值))
.计次循环尾 ()
字节集 = 到字节集 (数值数组)
返回 (字节集)

小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复 关闭延时

使用道具 举报

您需要登录后才可以回帖   登录 立即注册

高级模式

dannn

楼主

|Archiver|手机版|小黑屋|小栗子机器人社区

Powered by 小栗子机器人社区 X3.4 © 2001-2020 Comsenz Inc.