新干货-全自定义发邮件接口

[复制链接]
查看: 329   回复: 29
小陈同学 发表于 2020-10-8 10:18:47 | 显示全部楼层 |阅读模式
本帖最后由 茵茵的陈先森 于 2020-10-8 10:21 编辑

首次使用此方法搭建接口服务器,可能有未知原因导致bug的出现,如无法使用,请及时与我联系
游客,如果您要查看本帖隐藏内容请回复


QQID=【机器人QQ】&time=【当前时间戳】&bool=【SSL安全协议】&smtp=【Smtp服务器地址】&dk=【端口】&admin=【发件人用户名】&pass=【发件人密码或授权码】&name【发件人名称】&title=【邮件标题】&add=【收件人邮箱】&text=【发信内容】

【阿里云邮箱】SMTP服务器地址:smtp.aliyun.com(SSL加密端口:465;非加密端口:25)

【网易邮箱】SMTP服务器地址:smtp.163.com(端口:25) 

【QQ邮箱】SMTP服务器地址:smtp.qq.com(SSL加密端口:465/587;非加密端口:25)

注意,非加密端口,请将bool的值设置为:假,SSL加密端口,请将bool的值设置为:真

由于阿里云服务器不支持25端口,且587端口不知道什么原因,会导致程序崩溃,所以,目前暂时仅支持:465端口

您好,由于国际与国内均对垃圾邮件进行严格管控,我国《互联网信息服务管理办法》、《中国互联网协会反垃圾邮件规范》均对垃圾邮件进行说明与管理规范,为了共同维护良好的网络环境,鉴于服务器25端口被大量垃圾邮件充斥,严重影响广大用户正常使用,经专家讨论,阿里云自即日起新购服务器不再提供25端口邮件服务,同时也不支持25端口的解封,请您理解。阿里云建议使用SSL加密465端口发信,参考:https://help.aliyun.com/knowledge_detail/60692.html



.版本 2

.子程序 功能_网页访问, 文本型, , 本命令由【精易网页调试助手】生成,请配合精易模块使用。
.局部变量  局_网址, 文本型
.局部变量  局_方式, 整数型
.局部变量  ADD_数据包, 类_POST数据类
.局部变量  局_提交数据, 文本型
.局部变量  ADD_协议头, 类_POST数据类
.局部变量  局_提交协议头, 文本型
.局部变量  局_结果, 字节集
.局部变量  局_返回, 文本型
' http://jk.lovetly.top/jk-chuli
局_网址 = "http://jk.lovetly.top/jk-chuli"
局_方式 = 1
ADD_数据包.添加 ("QQID","”)
ADD_数据包.添加 ("time","")
ADD_数据包.添加 ("bool","")
ADD_数据包.添加 ("smtp","")
ADD_数据包.添加 ("dk","")
ADD_数据包.添加 ("admin","")
ADD_数据包.添加 ("pass","")
ADD_数据包.添加 ("name","")
ADD_数据包.添加 ("title","")
ADD_数据包.添加 ("add","")
ADD_数据包.添加 ("text","")

局_提交数据 = ADD_数据包.获取Post数据 ()
ADD_协议头.添加 ("User-Agent","Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36")

局_提交协议头 = ADD_协议头.获取协议头数据 ()

局_结果 = 网页_访问_对象 (局_网址, 局_方式, 局_提交数据, , , 局_提交协议头, , , , , , , , , , , )
局_返回 = 到文本(编码_编码转换对象(局_结果))
返回(局_返回)
.版本 2

.子程序 功能_网页访问, 文本型, , 本命令由【精易网页调试助手】生成,请配合精易模块使用。
.局部变量  局_网址, 文本型
.局部变量  局_方式, 整数型
.局部变量  ADD_数据包, 类_POST数据类
.局部变量  局_提交数据, 文本型
.局部变量  ADD_协议头, 类_POST数据类
.局部变量  局_提交协议头, 文本型
.局部变量  局_结果, 字节集
.局部变量  局_返回, 文本型
' http://jk.lovetly.top/jk-chuli
局_网址 = "http://jk.lovetly.top/jk-chuli"
局_方式 = 1
ADD_数据包.添加 ("QQID","”)
ADD_数据包.添加 ("time","")
ADD_数据包.添加 ("bool","")
ADD_数据包.添加 ("smtp","")
ADD_数据包.添加 ("dk","")
ADD_数据包.添加 ("admin","")
ADD_数据包.添加 ("pass","")
ADD_数据包.添加 ("name","")
ADD_数据包.添加 ("title","")
ADD_数据包.添加 ("add","")
ADD_数据包.添加 ("text","")

局_提交数据 = ADD_数据包.获取Post数据 ()
ADD_协议头.添加 ("User-Agent","Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36")

局_提交协议头 = ADD_协议头.获取协议头数据 ()

局_结果 = 网页_访问_对象 (局_网址, 局_方式, 局_提交数据, , , 局_提交协议头, , , , , , , , , , , )
局_返回 = 到文本(编码_编码转换对象(局_结果))
返回(局_返回)



本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复 关闭延时

使用道具 举报

小槑 发表于 2020-10-8 10:53:45 | 显示全部楼层
11111111111111111111111111111111111111111111111
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

幻 乐 发表于 2020-10-8 11:16:18 | 显示全部楼层
看帖看完了至少要顶一下,还可以加入到淘帖哦!
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

幻 乐 发表于 2020-10-8 11:17:17 | 显示全部楼层
在哪下载内
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

幻 乐 发表于 2020-10-8 11:29:00 | 显示全部楼层
源码呢?
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

 楼主| 小陈同学 发表于 2020-10-8 12:01:45 | 显示全部楼层

复制代码就行了啊
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

zhiyuan 发表于 2020-10-8 12:13:17 | 显示全部楼层
大佬牛皮
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

三级头 发表于 2020-10-8 14:27:58 | 显示全部楼层
11122222222
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

liu363998309 发表于 2020-10-8 19:20:00 来自手机 | 显示全部楼层
可以6666666696
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

553814886 发表于 2020-10-9 23:23:26 | 显示全部楼层
膜拜神贴,后面的请保持队形~
小栗子官网www.xiaolz.cn 小栗子程序更新请到官网下载
回复

使用道具 举报

123下一页
您需要登录后才可以回帖   登录 立即注册

高级模式

小陈同学

楼主

|Archiver|手机版|小黑屋|小栗子机器人社区

Powered by 小栗子机器人社区 X3.4 © 2001-2020 Comsenz Inc.